Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

CCPA delete

mmbb110
Level 8
Level 8

Hi Community,

I submitted a CCPA delete request via API and since 20 days it is still showing in processing state.

the profile data deletion is completed but the campaign still shows processing.

 

ccpa.JPG

 

I had submitted two jobs, once had a single email and other had three emails included in the payload, both were delete requests.

 

why does it take so much time any idea?

also when I looked at the technical workflows, I can see there are workflows for Get privacy requests from pipeline and Privacy delete requests and both are running fine .

 

The delete workflow has a frequency of daily and 3:40 am CST.

one thing that I noticed is in the delete workflow after the scheduler there is a JS used which only mentions about  loadLibrary("nms:gdpr.js");

 

I don't see anything about CCPA, is that something that is the reason for my request taking so long and may be stuck?

 

 

1 Accepted Solution
mmbb110
Correct answer by
Level 8
Level 8

By default the the two step process is enabled in Adobe campaign, the fix for this was to take off the '2-step approval' from the Campaign side since using API does not populate the request for approval within the ACS UI.

 

Restarted workflows and jobs completed fine.

View solution in original post

4 Replies
craigthonis
Employee
Employee

Hi mmbb,

 

The gdpr.js is expected here as the CCPA requirements are basically the California equivalent of the GDPR standards so the same logic applies.

 

It looks like there is some sort of caching/refresh issue since the requests and such are getting processed.  I'd recommend reaching out to Campaign Support as we'll likely need to review and engage the required internal teams to address this.

 

Thanks,

Craig

mmbb110
Level 8
Level 8
@craigthonis , Thanks you for your response, I will reach out to Support.
mmbb110
Level 8
Level 8
I have reached out to support and they are reviewing this further.
mmbb110
Correct answer by
Level 8
Level 8

By default the the two step process is enabled in Adobe campaign, the fix for this was to take off the '2-step approval' from the Campaign side since using API does not populate the request for approval within the ACS UI.

 

Restarted workflows and jobs completed fine.

View solution in original post