Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

API code

mmbb110
Level 8
Level 8

Hi Community,

I am seeing some strange issue for a real time Event for my transactional message.

In the event configuration I have used a coupon code field for my message. 

This attribute is defined in the html code twice. In the main content and at the footer.

 

When I test my transactional message using create test profile and hard code the coupon code in the personalize event configuration field, the email delivered has the coupon code defined properly in the email at both places.

 

The issue is when I use the payload and trigger the post api call, even though I have a value defined for the coupon code in my payload, when I get the email the coupon code is seen only in the main body of the mail and not the footer part.

 

At the footer it shows the attribute name instead.

 

Not sure what is wrong, I did check the html code and the attribute is defined correctly as well at both places.

 

5 Replies
ramon_bisswanger
Employee
Employee

Can you maybe post the HTML snippets you are using to add the fields?

mmbb110
Level 8
Level 8

@ramon_bisswangerI have attached two images from the html code. The not working one is at the footer of the email.

 

This one displays the code passed via the payload

 

code_display_working.JPG

 

The below shows the Abandoncartcode instead of the coupon code.

 

code_display_NOT_working.JPG

 

A email received example is also attached.

 

email_example.JPG

mmbb110
Level 8
Level 8
Any help please? As a part of some additional troubleshooting, I created a brand new event exactly similar to the affected one and used the personalize fields in the transactional message, I triggered api call and the dynamic values passed display fine in the email. Could the original issue be related some publishing glitch etc?
ramon_bisswanger
Employee
Employee
it could be. The HTML is looking fine. Can you maybe look at the "execution delivery" which was used to send the broken mail? i.e. the "2020/10 aaa" delivery. How does the HTML source look there?
mmbb110
Level 8
Level 8
I checked the html code of the DM from the execution list and it appears fine.