Adobe I/O-ACS

Avatar

Avatar

chan2111

Avatar

chan2111

chan2111

25-10-2019

I have tried to insert data into the custom resource linked with the profile schema but although the record is getting inserted I cannot view it in the ACS. I have confirmed that it is inserted by resending the same POST request which gave a unique constraint error.

Can you let me know why the view in custom resource is not showing the data.

Replies

Avatar

Avatar

johnwwilcoxmba

Avatar

johnwwilcoxmba

johnwwilcoxmba

25-10-2019

if you are using organization in your deployment make sure you use api profileAndServicesExt

Avatar

Avatar

prasannakumarmarru

Avatar

prasannakumarmarru

prasannakumarmarru

25-10-2019

Also You can validate by querying the results from the resource using a workflow, if you see the data then it should be resource screen definition issue or could be something like what John said above. Thanks!

Avatar

Avatar

chan2111

Avatar

chan2111

chan2111

30-10-2019

Could you explain in detail?

Avatar

Avatar

chan2111

Avatar

chan2111

chan2111

30-10-2019

Through the WF I am able to see the results but only in UI I am unable to see the values & data.

Avatar

Avatar

chan2111

Avatar

chan2111

chan2111

30-10-2019

For a 1:1 relationship I have created the link on the table other than profile and was able to see the data.

For a 1:M relationship if I create the link on the many side of the table A and link with the custom primary key to the FK in the recipient how do I insert data through the API do we have any sample payloads?