Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

System indicators error

Milan_Vucetic
Community Advisor
Community Advisor

Hi all,

does anyone experienced issue with system indicators in the Monitoring tab?

On every 3-4 refresh of page it shows indicators correctly and on others attempt an error is there:

Unable to parse XML response message of SOAP method 'DumpCurrentInstanceState' of service 'nl:monitoring'.

(1:1) : Invalid document structure

XML-110018 Error while parsing XML string 'grep: /proc/8282/status: No such file or directory

<?xml version="1.0" encoding="ISO-8859-1"?>

<indicators>

<indicator name='loadAvg1' label='Load Average (1 minute)'>

  <current label='Current Value' value='2.06'/>

  <warning value='6.4'/>

  <alert value='7.2'/>

  <max label='Max Value' value='8'/>

</indicator>

<indicator name='loadAvg5' label='Load Average (5 minutes)'>

  <current label='Current Value' value='2.09'/>

  <warning value='4.8'/>

  <alert value='5.4'/>

  <max label='Max Value' value='6'/>

</in'

Any ideas?

Thank you in advance,

Milan

3 Replies
somasundaramhal
Level 5
Level 5

Hi,

You can try to inspect this in a browser. So you can get an idea of what went wrong. Right click on monitor tab then copy&paste the link in a chrome/different browser. Login to AC in browser. Check for errors in the console tab. That might give you error related information. That is a way to check for errors.

Thanks.

Jyoti_Yadav
Community Advisor
Community Advisor

Hi,

Error which you are getting is because of lines written in your system indicator file: 'indicators.sh'

You can view this file at location: /usr/local/neolane/nl6/datakit/nl/indicators.sh

This is where you will see the error text mentioned and correct it.

Thanks.

Milan_Vucetic
Community Advisor
Community Advisor

Hi,

thank you all, responses are helpful.

Regards,

Milan