Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

$ sign rendering issue in SMS

lucyb20459049
Level 1
Level 1

Hello -

Has anyone experienced an issue where the $ sign in an SMS delivery is rendering as ¤ in proof and live sends? This seems to be happening randomly and will often fix itself after a few days.

Thanks in advance for any advice!

1 Accepted Solution
Milan_Vucetic
Correct answer by
Community Advisor
Community Advisor

Hi @lucyb20459049 ,

 

The data_coding field tells you which encoding is used. A major problem is that the value 0 means default SMSC encoding in the specification, in general it means GSM7, but that's not always the case. Check with the provider which encoding is associated with data_coding = 0 (AC only supports GSM7 for data_coding = 0). Other data_coding values tend to follow the specification, but the only way to be sure is to check with the SMSC provider.

 

Regards,

Milan

View solution in original post

2 Replies
Darren_Bowers
Community Advisor
Community Advisor

Hi @lucyb20459049 Check your encoding at both the campaign and service provider account end. If you are sending the wrong encoding to what they expect, this can cause some symbols to not print correctly. Most of the time you want GSM7 at both the campaign connector and the SMSC as this gives you the most characters per SMS. If your provider account is expecting something like US-ASCII and you send GSM-7 you wont see $ symbols or @ symbols most of the time.

Milan_Vucetic
Correct answer by
Community Advisor
Community Advisor

Hi @lucyb20459049 ,

 

The data_coding field tells you which encoding is used. A major problem is that the value 0 means default SMSC encoding in the specification, in general it means GSM7, but that's not always the case. Check with the provider which encoding is associated with data_coding = 0 (AC only supports GSM7 for data_coding = 0). Other data_coding values tend to follow the specification, but the only way to be sure is to check with the SMSC provider.

 

Regards,

Milan

View solution in original post