Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

Linking field value to Custom tag section ins web analytics

pradeep_07
Level 4
Level 4

Hey I have scenario where I want to populate the web analytics section custom tag with Campaign name(Folder name).

 

I know it can be entered manually while creating new deliveries, but I want this field to be populated dynamically when we create new delivery. I have trying to achieve this by adding some code in input forms. so far it did not work. Below is the code am using. Not sure where its going wrong and am sure its missing something.Any thoughts on this approach?

 

<postSave>

<if expr="@label != ''">

<set expr="Coalesce(@@label, 'defaultvalue can be anything that you want as default')" xpath="webAnalytics/@tag1"/>

<set value="nms:delivery" xpath="/ignored/writer/delivery/@xtkschema"/>

<set value="update" xpath="/ignored/writer/delivery/@_operation"/>

<set expr="[@id]" xpath="/ignored/writer/delivery/@id"/>

<soapCall name="Write" service="xtk:persist">

<param exprIn="[/ignored/writer/delivery]" type="DOMDocument"/>

</soapCall>

</if>

</postSave>

 

pradeep_07_0-1594827134844.png

Thanks,

 

Pradeep

Linking fields in web analytics
7 Replies
Manoj_Kumar_
Community Advisor
Community Advisor

Hello @pradeep_07 

 

If you want to have a the default value as Label add use the code below, instead of Post Save my suggestion would be to use enter. Because if the value is overridden manually then the value won't change because post-save will overwrite the manual entry.

 

The code to auto-populate the label will be 

<enter>
<set expr="iif(@label != '', @label, 'DEFAULT_VALUE_HERE')" xpath="webAnalytics/@tag1"/>
</enter>

 

Let me know if that works.

 

Thanks,

 

pradeep_07
Level 4
Level 4

Hi Manoj, I have enter the given code in input forms under nms:delivery and refreshed the deliveries. Still dont see the values in tag1.

 


Custom.JPG

 

 


 
Updating Media

 

Manoj_Kumar_
Community Advisor
Community Advisor
Hello Pradeep, You will have to logout from the adobe console and login again. Only then the changes will come in action.
pradeep_07
Level 4
Level 4

Hi Manoj , I logged out and logged in. Still dont see the values.tag1.JPG

pradeep_07
Level 4
Level 4
Hi, I was able to solve this issue by myself. I will post the solution.
Sukrity_Wadhwa
Employee
Employee
Hi @pradeep_07, The community would really appreciate if you could post your solution on this thread. It would help others facing the same issue. Thanks!