Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Maximum call stack size exceeded

jeffsabre
Level 2
Level 2

I seem to randomly get this error in the console and of course nothing fires. It seems to only happen on the first request into _satelitte and occurs on the getVar() function.

I cannot duplicate so unfortunately can't trace or set break points

Anyone else experience this or have an idea as to cause?

Thnx
Jeff

1 Accepted Solution
jantzen_belliston-Adobe
Correct answer by
Level 10
Level 10

It looks like this error can be caused by a number of JavaScript errors.

Internally, we've seen that error when the doPlugins runs more than once before a tag fires. Sometimes if two tags fire immediately one after another, we've also seen it. Could either of these situations be true for your site?

View solution in original post

11 Replies
jantzen_belliston-Adobe
Level 10
Level 10

Hi Jeff,

Do you have a URL where we can see this error? Also, how are you deploying DTM? Are the embed tags statically included on the page or are they dynamically inserted?


Thanks,
Jantzen

jantzen_belliston-Adobe
Level 10
Level 10

Hi Jeff,

Did you still need assistance with this issue? If not, would you mind posting the solution you found in case others face the same problem?

Thanks,
Jantzen

jeffsabre
Level 2
Level 2

I am not able to reproduce on demand so providing URLs will not be productive. It happens on a random basis

Thnx

Jeff

Site Optimization, Analytics and Reporting Principal

jantzen_belliston-Adobe
Level 10
Level 10

Understood. I'll leave this questions open in case others have seen anything.

jeffsabre
Level 2
Level 2

Just happened again on first page in session, console screen shot attached. Reload page and all is good

Thnx

Jeff

Site Optimization, Analytics and Reporting Principal

jantzen_belliston-Adobe
Level 10
Level 10

I'm not seeing the screenshot? Can you try attaching it again?

jeffsabre
Level 2
Level 2

And just got another one on first page reload. But it does not happen on every first page

MaxCallStack2.png

jeffsabre
Level 2
Level 2

If you want you can try to replicate here, seems to be happen more frequently

https://wl64-int.sabresonicweb.com/dx/MNDX/#/home

jantzen_belliston-Adobe
Correct answer by
Level 10
Level 10

It looks like this error can be caused by a number of JavaScript errors.

Internally, we've seen that error when the doPlugins runs more than once before a tag fires. Sometimes if two tags fire immediately one after another, we've also seen it. Could either of these situations be true for your site?

jeffsabre
Level 2
Level 2

I’ll have to pour through the code to see. At least it seems to only occur on the first hit for a session so that limits the rules, data elements and events I need to look through

Thanks for your help