Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Why always Mbox id is 0 in Adobe debugger?

adarshs7416688
Level 2
Level 2

Hi All,

Why always Mbox id is 0 in Adobe debugger? can you please help me to understand this and is there  any document/article on this

Screenshot:

1321866_pastedImage_0.png

Looking forward for response

Thank in advance,

Adarsh

1 Accepted Solution
DHopkinsAdobe
Correct answer by
Employee
Employee

This is because software/programming languages often count starting at zero instead of starting at 1.

If there's one mbox on the page, it would have the ID of 0. If there are three on a page, their IDs would be 0, 1, and 2.

Have a good day!

Daniel

View solution in original post

6 Replies
Amelia_Waliany
Employee
Employee

Thanks for your questions Adarsh! These might be a good first places to start in understanding why the mbox id is 0 in the debugger: Installing the Debugging Tools and Performing QA Steps.

Warmly,

Amelia

DHopkinsAdobe
Correct answer by
Employee
Employee

This is because software/programming languages often count starting at zero instead of starting at 1.

If there's one mbox on the page, it would have the ID of 0. If there are three on a page, their IDs would be 0, 1, and 2.

Have a good day!

Daniel

View solution in original post

adarshs7416688
Level 2
Level 2

Thank you so much Daniel and Amelia for info

Regards,
Adarsh