Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

latest version of at.js not working

mattf96384379
Level 2
Level 2

Hi,

I added Target 1.0.1 was via DTM install wizard, but with at.js added manually via the code section of Target (because DTM doesn't automatically implement at.js)

Since updating from 0.9.6 to 1.0.1 I can see warning messages but can't see any target tracking in the Adobe Cloud Console.
Plus there are some console message that suggest we need to make changes in the setting (see below)

What does this message mean? Does it mater?
mbox-contents-d0768a61657c891f27102502ae2940474a5e499b-staging.js:8 AT: Adobe Target content delivery is disabled. Ensure that you can save cookies to your current domain, there is no "mboxDisable" cookie and there is no "mboxDisable" parameter in query string.

If I use out the box mbox.js through DTM everything appears OK, but we require at.js due to the site being a Single Page App.

I have attached screen grabs of the error in the console, as well as the target cookies being deployed.

cookies_deployed.png

1 Accepted Solution
arturc85303583
Correct answer by
Employee
Employee

The are a couple of root causes for this error: "AT: Adobe Target content delivery is disabled. Ensure that you can save cookies to your current domain, there is no "mboxDisable" cookie and there is no "mboxDisable" parameter in query string"

- mboxDisable cookie or query string is present

- at.js can't save cookies on the current domain

at.js prior to version 1.2.0 couldn't save cookies to IP based addresses. This has been addressed in at.js 1.2.0. You can find more details here: at.js Version Details. Also you might check at.js FAQ, the FAQ tries to cover issues like these, here is the FAQ: at.js Frequently Asked Questions.

I would recommend upgrading to at.js 1.2.0 or later.

View solution in original post

9 Replies
arturc85303583
Correct answer by
Employee
Employee

The are a couple of root causes for this error: "AT: Adobe Target content delivery is disabled. Ensure that you can save cookies to your current domain, there is no "mboxDisable" cookie and there is no "mboxDisable" parameter in query string"

- mboxDisable cookie or query string is present

- at.js can't save cookies on the current domain

at.js prior to version 1.2.0 couldn't save cookies to IP based addresses. This has been addressed in at.js 1.2.0. You can find more details here: at.js Version Details. Also you might check at.js FAQ, the FAQ tries to cover issues like these, here is the FAQ: at.js Frequently Asked Questions.

I would recommend upgrading to at.js 1.2.0 or later.

View solution in original post

mattf96384379
Level 2
Level 2

Perfect thank you! I have since upgraded and this appears to have fixed the issue!

Regards,

Matt

ladann
Level 1
Level 1

Hi @arturc85303583

I'm also seeing the following warning:

AT: Adobe Target content delivery is disabled. Ensure that you can save cookies to your current domain, there is no "mboxDisable" cookie and there is no "mboxDisable" parameter in query string.

And can confirm I have the latest version of at.js loaded. Do you have any further troubleshooting steps to try? I'm trying to test a basic implementation of at.js here: Home Questionaire http://ladanazita.github.io/

Thanks!

ladann
Level 1
Level 1

I realize now that I needed to set the cookie domain — it works as expected now Thanks!

kimonp31365843
Level 4
Level 4

May I ask how you did this? I tried via AT Settings>Implementation but no luck. Maybe I am missing something?

Screen Shot 2019-04-01 at 17.02.19.png

Kind regards,

K.

piyush_mishra4
Level 1
Level 1

I am also seeing the same error:
AT: Adobe Target content delivery is disabled. Ensure that you can save cookies to your current domain, there is no "mboxDisable" cookie and there is no "mboxDisable" parameter in query string.

I am using Adobe Target extension in Adobe Launch to integrate this.

benoitl56052893
Level 1
Level 1

Hello,

Did you manage to fix your issue ?

kimonp31365843
Level 4
Level 4

I don't know if the original issue is fixed now, however I recently managed to fix this by providing the mbox property "at_property", with the value you get from Adobe Target for your property there.

 

This was required only in the case where we didn't use the default AT workspace for our activities.