Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Adobe Target Community Q&A Coffee Break: On Wednesday, February 1 at 8am PT, Brent Kostak of the Adobe Target Product team will be joining us to answer your Target questions. To register and for more information, follow the link to the right.

IMS Configuration in AEM - Unhealthy configuration

Avatar

Level 2

I am trying to integrate AEM with Adobe Target using IMS and I have done all the configurations mentioned in the below link.

https://experienceleague.adobe.com/docs/experience-manager-cloud-service/content/sites/integrations/... 

 

After completing the IMS configuration in AEM when I try to check health I am getting below error:

vignesh_bhat_0-1669704593401.png

Any idea what I am missing here.

 

5 Replies

Avatar

Level 9

Hi @vignesh_bhat 

 

Have you done the following steps mentioned in the document? Also what's the product profiles are you using?

 

  1. Open the Adobe Admin Console:

  2. Navigate to Products (top toolbar), then select Adobe Target - <your-tenant-id> (from the left panel).

  3. Select Product Profiles, then your required workspace from the list presented. For example, Default Workspace.

  4. Select API Credentials, then the required integration configuration.

  5. Select Editor as the Product Role; instead of Observer.

Avatar

Level 9

Hey @vignesh_bhat : Is your issue resolved?

Try with the steps mentioned above it will solve your issue. Let me know in case you face any issue.

Avatar

Level 2

Hi Avinash,

For default workspace I am not seeing API Credentials tab/option to change the privilege.

vignesh_bhat_0-1669973927235.png

Issue still exists.

Avatar

Level 9

Hi Vignesh,

Check with your administrator, might be your are not having permission to see the API Credentials tab.

Avatar

Level 2

Interestingly the issue was with Authorization Server URL. In the documentation its mentioned that we need to give the complete URL with API Key but it works when we give only the domain.

 

Ex:

Correct config - https://ims-na1.adobelogin.com

Wrong config - https://ims-na1.adobelogin.com/c/c95###042A###########56d