Expand my Community achievements bar.

Join us for the Adobe Journey Optimizer Community Q&A Coffee Break on 28th February at 8 am PT with Ariel Sultan, Daniel Wright, Josee Haeley and Rohit Basuri.
SOLVED

XDM schema custom attributes not appearing while creating build rule in segments

Avatar

Level 3

These Are the steps I followed to fetch the attribute for creating build rule segments

1.Created XDM individual profile with custom attributes.
2.Created a dataset for it and load the csv data from local system in to respective dataset.
3.Data has uploaded successfully.
4.I checked in XDM individual profiles>Aeppsemea But couldn't find the attribute also attached a image for reference
Kindly let me know if I missed anything.

VV97_0-1699944548472.png

 

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

1 Accepted Solution

Avatar

Correct answer by
Level 6

Hi @vani97  - Couple of things that you can check to make sure your profiles attributes are visible in segment to build your audience. 
1. Make sure both schema and datasets are profile enabled. if not, request you to do that and make sure to validate your data with profile service (Profile --> Browse --> respective identity namespace & its value). 
2. Select settings on audience, see what has been selected under "available fields" and merge policy. if you see data in profile, select "show only fields with data" if not for time being select "show full XDM schema".
Hopefully you will see the attributes. 

 

View solution in original post

4 Replies

Avatar

Employee Advisor

Are the schema and dataset both enabled for profile? Can you look up a profile and confirm that the attribute data has landed as expected?

Avatar

Level 3

Hi @dwright -I enabled both the XDM schema and Datasets the only thing I haven't Include person Id in my csv data while ingesting data from local file system Now I could see the attributes in segment builder.

Thanks !

Avatar

Correct answer by
Level 6

Hi @vani97  - Couple of things that you can check to make sure your profiles attributes are visible in segment to build your audience. 
1. Make sure both schema and datasets are profile enabled. if not, request you to do that and make sure to validate your data with profile service (Profile --> Browse --> respective identity namespace & its value). 
2. Select settings on audience, see what has been selected under "available fields" and merge policy. if you see data in profile, select "show only fields with data" if not for time being select "show full XDM schema".
Hopefully you will see the attributes. 

 

Avatar

Level 3

Hi @jayakrishnaaparthasarathy -I enabled both the XDM schema and Datasets the only thing I haven't Include person Id in my csv data while ingesting data from local file system Now I could see the attributes in segment builder.

Thanks!