Expand my Community achievements bar.

SOLVED

Segment data not sending to ACS SFTP destination - even though segment profile count is > 0

Avatar

Level 6

Hi there,

 

I have a test segment with 2 profiles realized in it. Currently, the source of the profiles are only from XDMIndividualProfile (offline data), as we are still working through the data implementation for XDMExperienceEvents (online data). I tried activating the segment to the ACS SFTP destination, but the dataflow result says, 0 profiles received, 0 failed, 0 excluded. 

 

I ensured that the attributes I chosen to send are populated and have some certain values, I especially included the primary identity in there. Is it because I don't have XDMExperienceEvents data that the profiles are not complete so I cannot activate the profiles to the destination?

 

Thanks,

Alan

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

@akwankl It's not mandate to have exp events for profiles to work, when you created the segment did it show any count of profile ? 

Also the segment you created were batch? if yes they will take 24hrs to get realised. 

 

 

View solution in original post

3 Replies

Avatar

Correct answer by
Community Advisor

@akwankl It's not mandate to have exp events for profiles to work, when you created the segment did it show any count of profile ? 

Also the segment you created were batch? if yes they will take 24hrs to get realised. 

 

 

Avatar

Level 6

Hi @Anil_Umachigi , yes when I created it showed 2 counts (small count as it was a test segment). 

 

The segment is a batch, but I created a segment job request with the API before activating it, and I used the entity service api to ensure the profiles was in the segment too.

 

 

Avatar

Community Advisor

@akwankl right ok, did those 2 segments count show when you were sharing the segment with destination?