Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Adobe Experience Platform DCS Endpoint

Avatar

Level 3

Hello Team,

 

My call for DCS endpoint on my website is failing due to wrong values in header.

My IMSOrg ID and schema reference ID (schemaRef) is pointing to wrong organisation, even when all other value is correct in header.

I am getting error 400 ( "Invalid XDM Message Format") and in reports "Message has wrong imsOrgId in the header".

 

How can I send the correct IMSOrg ID and SchemaRef in my headers and why are they wrong even when my DCS endpoint is in the correct organisation sandbox ?

 

Thanks in advance,

Singh

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

1 Accepted Solution

Avatar

Correct answer by
Level 1

Use Adobe Launch to deploy the JavaScript to get rid of the authentication issue. Despite using launch, Content-Type, sandbox-name, and Authorization are the only headers that are required. Make sure you are on a correct sandbox and in the left navigation rail, click on Sources and open Accounts tab and click on HTTP API to select the row. On the right side, scroll down to the Streaming endpoint and make sure to copy it from there.

View solution in original post

1 Reply

Avatar

Correct answer by
Level 1

Use Adobe Launch to deploy the JavaScript to get rid of the authentication issue. Despite using launch, Content-Type, sandbox-name, and Authorization are the only headers that are required. Make sure you are on a correct sandbox and in the left navigation rail, click on Sources and open Accounts tab and click on HTTP API to select the row. On the right side, scroll down to the Streaming endpoint and make sure to copy it from there.