Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Form submission not firing rule in Adobe Launch to set evar

e30powar
Level 3
Level 3

Seems like a basic function of launch so not sure what I am doing wrong. I have created a rule in Launch with an event = Core-Submit. I tried setting it to a specific element = #pardot-form which is the ID in the code. I then switched it to "any element" and it still did not fire. I have no conditions set and the actions are to set variables and send the adobe analytics beacon. 

 

When I look at the adobe debugger on the form page, you can see the launch tag on the form is working as context data is captured and global link clicks, but nothing shows up in the logs or the analytics tab for the rule after hitting submit.

 

e30powar_0-1613148699751.png

 

10 Replies
Andrey_Osadchuk
Community Advisor
Community Advisor

Is the button <input type="submit"> ?

e30powar
Level 3
Level 3
Yes, <input type="submit" accesskey="s" value="Submit Your Request">. If it helps this is using a Pardot landing page.
e30powar
Level 3
Level 3
Yes, input type="submit" accesskey="s" value="Submit Your Request". If it helps this is using a Pardot landing page.
 
 
 
e30powar
Level 3
Level 3

UPDATE: The rule is firing properly. The set variable action wasn't set properly so the eVar was being populated with "null" . Now the problem is the rule fires every time the form is submitted. Including if you leave the fields blank, click submit, and the page reloads with required field errors.

yuhuisg
Community Advisor
Community Advisor
@e30powar isn't that the correct behaviour, though? The form was submitted after all.
e30powar
Level 3
Level 3
Yes I guess that is correct from a programming standpoint, no error there. But how do I get it to fire only when the submit is successful? Like Core > Form Submit AND "No Errors"
yuhuisg
Community Advisor
Community Advisor
@e30powar Perhaps you can move your form submission tracking to the next page. So if it's a valid Thank You page, then you can track your form submission there.
jsvasu
Level 3
Level 3
@ yuhuisg I have almost the same issue. I have built a Click event rule in launch for the "Submit" button. But this rule is firing even if you just click submit button even if the fields of the form are not entered. Any solution on that?
yuhuisg
Community Advisor
Community Advisor
@jsvasu Try using the Form Submit event instead. If you still need help, I suggest opening a new forum post instead of continuing here.