Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

WYSIWYG html editor glitches (Rich text)

Avatar

Avatar
Validate 1
Level 1
abhishekt945679
Level 1

Likes

0 likes

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
abhishekt945679
Level 1

Likes

0 likes

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
abhishekt945679
Level 1

18-04-2018

I am facing a issue with WYSIWYG html editor (rich text),

The HTML editor in the WYSIWYG component is acting erratic in AEM 6.3. The issue is causing html editing to render a blank input field.

Steps:

To recreate this:

1. Edit WYSIWIG

2. Fullscreen/Expand

3. Click "Source Edit"/HTML icon.

4. Click minimize.

5. HTML will not be saved

6. Click fullscreen/Expand

7. Click "Source Edit"/HTML again

8. HTML source will now be blank

9. Click fullscreen/Expand

10. "Source Edit"/HTML icon will now be gone

I have tried to configured with below link and also install the content packages which given there but still having same issue.

Can any one help for this issue.

Thanks

Abhishek

Replies

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

18-04-2018

Can you post a screenshot and show me what you mean by a WUSIWUG editor. Are you referring to the RTE in a Text Component for example?

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

18-04-2018

I have entered text into the RTE and done what you said - I am not seeing the Source Button disappear.

Pic46.png

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

18-04-2018

Also - to be clear - the HTML is saved when you click the checkmark button.

Pic47.png

Avatar

Avatar
Validate 1
Level 1
abhishekt945679
Level 1

Likes

0 likes

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
abhishekt945679
Level 1

Likes

0 likes

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
abhishekt945679
Level 1

18-04-2018

Hi

Thanks for reply,

Can you please follow the below steps only:

1. Edit WYSIWIG

2. Fullscreen/Expand

3. Click "Source Edit"/HTML icon.

4. type any text

5. Click minimize.

6. HTML will not be saved (when will you click the checkmark button then text will clear, it'll not save)

I'll also provide you screenshots as well after some time.

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

18-04-2018

No matter how many times that i minimize or maximize the RTE by  clicking the Toggle button - the text remains.

Pic48.png

Can you try in a fresh AEM 6.3 DEV instance. Try installing this package -- Configuring Experience Manager Rich Text Editor Plugins in a Touch UI Component Dialog

Let me know if you still get these results.

Avatar

Avatar
Validate 25
MVP
Ratna_Kumar
MVP

Likes

158 likes

Total Posts

755 posts

Correct Reply

134 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give Back 50
Give Back 5
View profile

Avatar
Validate 25
MVP
Ratna_Kumar
MVP

Likes

158 likes

Total Posts

755 posts

Correct Reply

134 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give Back 50
Give Back 5
View profile
Ratna_Kumar
MVP

18-04-2018

Hi Abhishek,

I tried the below steps you have mentioned.

-> Once I expand and click Source Edit/HTML icon, and i enter text and I minimize, I see as per the below screenshot.

sourceedit1.PNG

Here, for me HTML is saving and also when I click on check-mark button, text is existing in my case. It is saving!!

I suggest you to try in fresh instance and install the package as discussed in the article and let us know: Configuring Experience Manager Rich Text Editor Plugins in a Touch UI Component Dialog

Thanks,

Ratna.

Avatar

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,166 likes

Total Posts

6,281 posts

Correct Reply

1,144 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,166 likes

Total Posts

6,281 posts

Correct Reply

1,144 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile
kautuk_sahni
Community Manager

18-04-2018

Unless you save the content, it would not get saved.

You need to click on right sign to get it saved. Also, not everything of RTE is available in in-place.

Table plugins and the source-edit feature are not available for in-place editing in the touch-enabled UI.

Doc:- Configuring the Rich Text Editor

Avatar

Avatar
Validate 1
Level 1
abhishekt945679
Level 1

Likes

0 likes

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
abhishekt945679
Level 1

Likes

0 likes

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
abhishekt945679
Level 1

20-04-2018

Hi Ratna,

I have flowed the steps (given in below link)and install the package on my local,

link : Configuring Experience Manager Rich Text Editor Plugins in a Touch UI Component Dialog

but still facing issue, here I am attaching screenshot as well, I have debug the code as well I found "createNodeList, function not triggering in richtext.js file when author Click "Source Edit"/HTML icon"

May be its my local instance issue,

1. installed the given package

Screen Shot 2018-04-20 at 2.03.02 PM.png

2. author the component.

Screen Shot 2018-04-20 at 2.05.25 PM.png

3. text is not save,

Screen Shot 2018-04-20 at 2.05.37 PM.png

Thanks

Abhishek

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

20-04-2018

Try this on a fresh AEM instance. I have not seen this behaviour on my AEM instance nor other community members that have tried this such as Ratna.