Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Workflow Launcher for Content Fragment

Mahamood
Level 3
Level 3

I have create workflow launcher which need to be trigger when new content fragment is created under /content/dam/myfragments folders.

 

But considering with in content fragment any nodes getting created under the parents node there are multiple workflow instance triggered for the same content. . I believe it should trigger only when Content Fragment completely created but not to each of its child node.

 

 

In workflow console I can see the launcher triggered for each of this path but it should trigger only for this content fragment "/content/dam/myfragments/mahamood-bio2"

 

/content/dam/myfragments/mahamood-bio2/jcr:content

/content/dam/myfragments/mahamood-bio2/jcr:content/metadata

/content/myfragments/mahamood-bio2/jcr:content/data

/content/myfragments/mahamood-bio2/jcr:content/data/master

/content/myfragments/mahamood-bio2/jcr:content/related

 

Please advice how to create launcher for Content Fragment.

pastedImage_0.png

1 Accepted Solution
Veena_Vikram
Correct answer by
Community Advisor
Community Advisor

Hi Mahamood,

 

    I have not tried this out. But Just wondering if you can make use of Conditions field. You can add one condition per launcher. If you can listen for a particular property from your expected node, may be your issue can be solved. Just go through this link once and see if this solves your issue. 

 

Thanks

Veena

View solution in original post

1 Reply
Veena_Vikram
Correct answer by
Community Advisor
Community Advisor

Hi Mahamood,

 

    I have not tried this out. But Just wondering if you can make use of Conditions field. You can add one condition per launcher. If you can listen for a particular property from your expected node, may be your issue can be solved. Just go through this link once and see if this solves your issue. 

 

Thanks

Veena

View solution in original post