Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

WKND tutorial - loading blank page

soniv
Level 1
Level 1

After installing a WKND bundle. the sites shows the blank page. and when I open the page with View as Published it gives me an error.

 

org.apache.sling.api.SlingException: Cannot get DefaultSlingScript: org.apache.sling.api.scripting.ScriptEvaluationException: data-sly-set: None of the registered plugins can handle the data-sly-set block element. in /apps/wknd/components/page/favicons.html at line number 17 at column number 7

1 Accepted Solution
Asutosh_Jena_
Correct answer by
Community Advisor
Community Advisor

Hi @soniv 

 

Can you check if all the bundles are active in system console.

http://localhost:4502/system/console/bundles

 

Also which version of AEM you are using and what is the JDK version?

If it's AEM 6.5 with JDK 11 then please make the below lines of changes in sling.properties file under crx-quickstart/conf folder.

 

from sling.bootdelegation.sun=sun.*,com.sun.*

to sling.bootdelegation.sun=sun.*,com.sun.*,jdk.internal.reflect,jdk.internal.reflect.*

 

Thanks!

View solution in original post

0 Replies
Asutosh_Jena_
Correct answer by
Community Advisor
Community Advisor

Hi @soniv 

 

Can you check if all the bundles are active in system console.

http://localhost:4502/system/console/bundles

 

Also which version of AEM you are using and what is the JDK version?

If it's AEM 6.5 with JDK 11 then please make the below lines of changes in sling.properties file under crx-quickstart/conf folder.

 

from sling.bootdelegation.sun=sun.*,com.sun.*

to sling.bootdelegation.sun=sun.*,com.sun.*,jdk.internal.reflect,jdk.internal.reflect.*

 

Thanks!

View solution in original post

soniv
Level 1
Level 1

I am using adobe 6.4 with  java version:1.8.0_282

I have go this when I looked at bundle.

Screen Shot 2021-04-30 at 2.06.59 PM.png

Asutosh_Jena_
Community Advisor
Community Advisor

Hi @soniv 

 

The WKND Project has been designed for AEM as a Cloud Service.

It is also backward compatible with AEM 6.4.8.0 and 6.5.5.0 by adding the classic profile when executing a build, i.e:

 

mvn clean install -PautoInstallSinglePackage -Pclassic

 

Please try the above command and ensure you are running minimum of AEM 6.4.8.0 version.

 

Thanks! 

soniv
Level 1
Level 1

Screen Shot 2021-04-30 at 2.26.24 PM.pngHi @Asutosh_Jena_,

After running the command. i have got new error.

org.apache.sling.scripting.sightly.SightlyException: Compilation errors in org/apache/sling/scripting/sightly/apps/core/wcm/components/page/v2/page/page_html.java: Line 28, column 1274 : Only a type can be imported. com.adobe.cq.wcm.core.components.models.Page resolves to a package Line 48, column 2025 : Page cannot be resolved to a type

 

 

Asutosh_Jena_
Community Advisor
Community Advisor

Hi @soniv 

Are you running AEM 6.4.8.0 or greater version?

Also please check if you have the AEM core components package installed on your instance. I just tried this and it works for me.

 

Thanks!

soniv
Level 1
Level 1

Hi @Asutosh_Jena_,

I am using 

Installed Products
  Adobe Experience Manager (6.4.0)

Screen Shot 2021-04-30 at 3.27.50 PM.png

installed packages

Asutosh_Jena_
Community Advisor
Community Advisor

Hi @soniv 

 

You need to download the service pack 6.4.8.0 and install it on your machine.

As per WKND tutorial it has to be minimun of AEM 6.4.8.0. Please see the link below with Building for AEM 6.x.x section.

https://github.com/adobe/aem-guides-wknd

 

You can download the 6.4.8.0 version from Adobe Package Share i.e. by logging into https://experience.adobe.com/#/downloads/content/software-distribution/en/aem.html with your adobe experience cloud id.

 

Thanks!

soniv
Level 1
Level 1

Hi @Asutosh_Jena_,

Do we have instruction on how to install the service pack 6.4.8 
I have uploaded and installed the package via package manager and restarted the instance but it still show the 6.4.0 version as well it still has the same error I've got previously.

Asutosh_Jena_
Community Advisor
Community Advisor

Hi @soniv 

 

You need to login to Package Manager and add the downloaded AEM 6.4.8.0 package.

Select the uploaded package and click Install.

Monitor the error.log. It will take around 5-7 min to complete the installation process. Once the installation is complete navigate to http://localhost:4502/system/console/productinfo

 

It will show Installed Products (Adobe Experience Manager (6.4.8.0))

 

https://experienceleague.adobe.com/docs/experience-manager-64/release-notes/sp-release-notes.html?la...

 

Thanks!