Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

WKND Tutorial - Chapter 8 Unit Testing Missing

Avatar

Level 2

Hi,

I noticed that Chapter 8 Unit Testing  in WKND tutorial Getting Started with AEM Sites - WKND Tutorial  is missing. Is it on purpose?

I tried to google for the same in internet. Although it returned me a link but it is broken Adobe Experience Manager Help | Getting Started with AEM Sites Chapter 8 - Unit Testing

Regards,

Sandeep

1 Accepted Solution

Avatar

Correct answer by
Level 2

smacdonald2008​ I was able to figure out why it happened. It seems that the content is blocked for India. I used a VPN and accessed the site using US server and I was able to see the content.

Thanks,

Sandeep

View solution in original post

15 Replies

Avatar

Community Advisor

Do you mean that you are not able to find and load Chapter -8? I'm able to load it properly.

Avatar

Level 2

Yes. Can you share the link? Its about unit testing. If you click the

second link that i shared above its broken. And the actual tutorial doesnt

have the link for 8th Chapter.

Regards,

Sandeep

Avatar

Community Advisor

Well, the same link that you posted works fine

Adobe Experience Manager Help | Getting Started with AEM Sites Chapter 8 - Unit Testing

Clear browser cache or try with a different browser/network.

Avatar

Level 2

Strange I am still getting 404 error. I tried with mobile browser now.

Avatar

Community Advisor

Works for me on cell phone.

smacdonald2008​, could you check this?

Avatar

Level 2

Strange. I believe i may not have permission to view the page or something

or my role might be different than yours or something. Hence may be getting

this error.

Regards,

Sandeep

Avatar

Level 10

Try on another computer. This is an open document and not protected or anything like that!

Avatar

Level 2

Hello smacdonald2008​,

Thanks for replying. I still am not able to see it. I have tried two laptops and mobile browser. If you see the below screen, I have highlighted how Chapter 7's link is enabled for me whereas Unit Testing there is no link

Screen 1.png

Please see the second screen where I directly tried the URL from google.

Screen 2.png

Avatar

Level 2

Any idea why this is happening to me.

One question is if you have seen my first screenshot in last reply you can see "Unit Testing" is bolded out with no link, whereas "Teaser and Carousel Extension" where href is there is shown as link. Is that how AEM deals with showing links which doesnt have permission. In that case it definitely is a permission issue.

Second question is have you tried with login or without login? I believe it should happen to you without login if its a permission issue and it may be happening to me since my role might not have permission

Screen 1.png

Avatar

Correct answer by
Level 2

smacdonald2008​ I was able to figure out why it happened. It seems that the content is blocked for India. I used a VPN and accessed the site using US server and I was able to see the content.

Thanks,

Sandeep

Avatar

Level 10

Thanks for posting solution. First time I have heard of that.

Avatar

Level 2

Yeah me too. If you do the same thing but proxy via India, you should have issue replicated

Avatar

Community Advisor

This behavior might be restricted to the proxy that you've mentioned. You may try to access without the proxy settings in browser.