Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

while I'm hitting experience fragments on browser "undefined" 404 coming

Avatar

Level 2

while I'm hitting experience fragments on browser "undefined" 404 coming in network tab

 

this request coming from all experience fragments::

 

https://google.com/content/experience-fragments/xyz/ab/pl/hts/asing/advertising/cstem/undefined?id=u...

keshava219_0-1654089795520.png

please let me know, how will solve this issue 

 

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Hi @keshava219 - Your URL seems to be incorrect with /undefined in the path. How are you grabbing this URL of Experience fragment? Ideally the last element in your XF url should be the variation you are trying to access, and for all XF's a default variation of master exists. So, try accessing your XF with replacing undefined as master.
If still doesn't work, the XF might not be published and so re-publish.

View solution in original post

3 Replies

Avatar

Correct answer by
Community Advisor

Hi @keshava219 - Your URL seems to be incorrect with /undefined in the path. How are you grabbing this URL of Experience fragment? Ideally the last element in your XF url should be the variation you are trying to access, and for all XF's a default variation of master exists. So, try accessing your XF with replacing undefined as master.
If still doesn't work, the XF might not be published and so re-publish.

Avatar

Community Advisor

Hi @keshava219 

Seems something wrong in constructing URL for accessing Experience Fragment in your custom implementation- Identify what is undefined? It should be Master and/or Variant uses. The plain HTML rendition adds the protocol, host and context path.
eg. 

 

"/content/experience-fragment/master"

 


Reference: https://experienceleague.adobe.com/docs/experience-manager-cloud-service/content/implementing/config...

Hope that helps!

Regards,
Santosh

Avatar

Community Advisor

Is this issue happening on author also? Is your url is getting redirected and appending undefined at the end ? Check if there is any custom code which updates the url to select the variant which might be not working properly.