Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

WCM Components Core Bundle not active

Avatar

Level 3

After building the project, 

"Adobe Experience Manager Core WCM Components Core Bundle com.adobe.cq.core.wcm.components.core" is not in active state. Hence no pages are loading.

com.day.cq.wcm.api,version=[1.28,2) -- Cannot be resolved

org.apache.sling.api.servlets,version=[2.3,3) -- Cannot be resolved

 

Error in log file

*ERROR*  org.apache.felix.http.jetty %bundles.pluginTitle: Cannot start (org.osgi.framework.BundleException: Unable to resolve com.adobe.cq.core.wcm.components.core [579](R 579.1): missing requirement [com.adobe.cq.core.wcm.components.core [579](R 579.1)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.wcm.api)(version>=1.28.0)(!(version>=2.0.0))) Unresolved requirements: [[com.adobe.cq.core.wcm.components.core [579](R 579.1)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.wcm.api)(version>=1.28.0)(!(version>=2.0.0)))])
org.osgi.framework.BundleException: Unable to resolve com.adobe.cq.core.wcm.components.core [579](R 579.1): missing requirement [com.adobe.cq.core.wcm.components.core [579](R 579.1)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.wcm.api)(version>=1.28.0)(!(version>=2.0.0))) Unresolved requirements: [[com.adobe.cq.core.wcm.components.core [579](R 579.1)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.wcm.api)(version>=1.28.0)(!(version>=2.0.0)))]

 

Kindly help me on this. Thanks in advance

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Below you could see I am having similar issue after installing wcm core component package -

 

DEBAL_DAS_2-1645775085139.png

 

 

DEBAL_DAS_0-1645774917006.png

DEBAL_DAS_1-1645774955852.png

Now after installing AEM service pack 6.5.9 , these dependency issue got resolved -

DEBAL_DAS_3-1645775774383.png

 

Please let us know AEM version, wcm core components version like 2.17.14 then we can give a try to fix this issue with relevant service pack.

 

Hope this will help.

 

View solution in original post

3 Replies

Avatar

Correct answer by
Community Advisor

Below you could see I am having similar issue after installing wcm core component package -

 

DEBAL_DAS_2-1645775085139.png

 

 

DEBAL_DAS_0-1645774917006.png

DEBAL_DAS_1-1645774955852.png

Now after installing AEM service pack 6.5.9 , these dependency issue got resolved -

DEBAL_DAS_3-1645775774383.png

 

Please let us know AEM version, wcm core components version like 2.17.14 then we can give a try to fix this issue with relevant service pack.

 

Hope this will help.

 

Avatar

Level 3

Previously, AEM version installed was 6.3. Installed AEM 6.5. Worked fine. Thanks 

Avatar

Community Advisor

if I don't install any specific wcm core component version then I could see below information -

 

DEBAL_DAS_0-1645796445620.png