Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Versioned clientlibs not working for js

Avatar

Level 4

ACS Commons Versioned clientlibs is not applying for all the js files on the page. It is working in higher environments and not in local.

 

Any idea why this is happening?

1 Accepted Solution

Avatar

Correct answer by
Level 4

Got the fix. was using older version of acs commons which is not compatible with 6.5.7 version of aem and hence the issue. It will be resolved in ACS 4.11.2 version

View solution in original post

8 Replies

Avatar

Community Advisor

@MohitKumarK,

It might be because your configuration has not set properly. Sure that the configuration is set under an active run mode in your local AEM. Can you share with us the location of the file where the versioned-clientlibs.xml lives, and also its configuration?

Documentation can be found here: https://adobe-consulting-services.github.io/acs-aem-commons/features/versioned-clientlibs/index.html

 

Avatar

Community Advisor
Can you check in your local author development AEM, look for at a page in disabled mode, is this the same issue where only the CSS is ACSHASHED?

Avatar

Correct answer by
Level 4

Got the fix. was using older version of acs commons which is not compatible with 6.5.7 version of aem and hence the issue. It will be resolved in ACS 4.11.2 version

Avatar

Level 1

Thank you . It is working for me after i upgraded ACS version . But we have observing that type=text/javascript is missing from the genrated client libs .  Any idea how to fix this .