Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Unable to Sign in to the local AEM 6.5 Publish Instance

zameer_abbas
Level 2
Level 2

Hi,

 

I am not able to Sign in to AEM 6.5 Publish Instance. I cleared up the cache and cookies and still not able to login. 
I have signed in from the machine and with the same set up earlier as well. When I click on the login button I only get to see the 'Preference'. 
Please suggest what could be the issue here.

zameer_abbas_0-1602569805479.png

 

1 Accepted Solution
dan_stelmakh
Correct answer by
Level 2
Level 2

@zameer_abbas do you have this issue an a vanilla AEM 6.5 instance? I have the  similar one after Service Pack 6  installation. I haven't found the root cause yet. Meanwhile, you should be able to use /libs/granite/core/content/login.html as a workaround at the moment I guess.

View solution in original post

2 Replies
santhosh_kumark
Community Advisor
Community Advisor

Hi @zameer_abbas ,

 

1. Are you able to access http://localhost:4503 for publish which will redirect to http://localhost:4503/content/we-retail/us/en.html by default. If not there might be an issue with configuring publish instance setup.

2. Can you try running the same publish instance on other port number and check it(Ex:8080).

 

Links: https://helpx.adobe.com/in/experience-manager/6-3/sites/deploying/using/deploy.html

          http://aemconcepts.blogspot.com/2016/08/setting-up-author-and-publish-instance.html

 

Regards,

Santosh

zameer_abbas
Level 2
Level 2
Hi Santosh, I am able to access http://localhost:4503/content/we-retail/us/en.html but I can't see any changes I am publishing from the author environment. When I tried to sign in into the CRX, I couldn't.
santhosh_kumark
Community Advisor
Community Advisor
Can you check for the error log and console for if there are any Login/Repository exceptions.
Nikhil-Kumar
Community Advisor
Community Advisor

@zameer_abbas  - Which version of AEM are you using ? 
Can you try restarting the server or try any other browser also check for any errors in console.

@vanegi @Arun_Patidar  Any suggestions on this ?

Arun_Patidar
Community Advisor
Community Advisor
CRXDE login is restricted onwards 6.5.5.0. You need to use /libs/granite/core/content/login.html
Nirmal_Jose
Community Advisor
Community Advisor

Are you able to login into system console. If so,

1. Do you see any bundles not in active state. If so, please make them active

2. Open http://localhost:4502/system/console/configMgr/org.apache.sling.jcr.webdav.impl.servlets.SimpleWebDa... and ensure rooth path is /crx/repository

zameer_abbas
Level 2
Level 2
All bundles are in active state as well. root path is also as expected. It's /crx/repository
Nirmal_Jose
Community Advisor
Community Advisor

Interesting, can you ensure http://localhost:4502/system/console/configMgr/org.apache.sling.jcr.davex.impl.servlets.SlingDavExServlet is /crx/server as well, thanks

vanegi
Employee
Employee

To debug and investigate the use case, please check the following:

I. Validate the user name, password, and that the user exists:
If the issue only happens with one or a few users, then it could be that the wrong user names or passwords are being used or the users don't exist in AEM.

 

Check the password:
Use Chrome browser and open Developer Tools => Network tab in the browser, then, attempt to log in again.
Select the POST request ending with j_security_check in the URL.
In the lower-right panel of the Headers tab, scroll to the bottom.
Validate that under Form Data, the password being sent in the j_password parameter is correct.

 

VALIDATE THAT THE USER EXISTS AND RESET THE PASSWORD:
Log in as admin user.
Go to the user administration screen.
Verify that the users exist.
Create the user if it doesn't exist or reset the password if it does.

 

II. Analyze broken authentication handling
If none of the above solves the problem, then:

Log in to the AEM server's OS.
Tail or view the error.log file.
View the updates to the log while attempting to log in to AEM.
If any errors or warnings are logged, then analyze those warnings. If nothing is logged, then enable a debug log with these settings:

Log Level: Debug
Log File: auth-debug.log
Loggers:
org.apache.sling.auth
com.adobe.granite.auth
com.day.crx.security.token

 

 

Also, can you try restarting the instance? If you end up needing to reset the password you could try to package the admin user account from another instance (/home/users/whatever), then put that package in a /crx-quickstart/install folder on the local filesystem. The instance will pick it up and install it automatically. 

 

dan_stelmakh
Correct answer by
Level 2
Level 2

@zameer_abbas do you have this issue an a vanilla AEM 6.5 instance? I have the  similar one after Service Pack 6  installation. I haven't found the root cause yet. Meanwhile, you should be able to use /libs/granite/core/content/login.html as a workaround at the moment I guess.

View solution in original post

zameer_abbas
Level 2
Level 2
@Dan_stemakh Yes it is an vanilla AEM 6.5 instance. This work around worked for me. Thank you so much. However, I still don't understand what exactly is the issue here. Regards.
aemmarc
Employee
Employee
No root cause? Authentication in via CRX DE was removed from the product and documented in the release notes.
kerr
Level 2
Level 2

As part of a recent Service Pack the login/logout functionality has been removed from CRX/DE Lite.

pgupt153
Level 1
Level 1

Is this for only Publish instance or for Author as well ?
As for author, crx/de redirects to the default login page but for publish it doesn't.