Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Touch UI Multifield in Page Properties

Avatar

Level 4

Hello Everyone,

I have a requirement in which user can enter multiple values for Page Title and Page Path which is a multifield together.

I have created the dialog using the below post 

http://experience-aem.blogspot.in/2015/02/aem-6-sp2-touch-ui-multi-field-component.html

 

The above post tutorial works best for component dialog. But when it comes to page properties it is not working as expected.

Can someone help me or with some samples where it uses multifield (Page Title and Pate Path).

I have been struggling since few days on this. Please Help!!

5 Replies

Avatar

Level 10

Most examples are for component dialogs. What is your business requirement to modify page properties?

Avatar

Level 2

Hello,

I have a scenario wherein i have a separate template for pages showing course details and course timings. There are two components built(coursedetails and coursetimings) which display details about location wise timings of courses. These components fetch data entered via Page Properties dialog shown below with using java classes:

1391826_pastedImage_4.png

and below is the screenshot how it gets displayed on the page:

1391827_pastedImage_5.png

Whenever we again open the Page Properties dialog these multifield data disappears. Normal component dialogs are able to retain data from multifields in my project, but in case of Page Properties its failing.  How should i make it work ?

Regards,

Surendra

Avatar

Level 1

Hi, I am trying to use the acs commons multifield into the page properties in AEM 6.3 and it does not work (JSON_STORE). For component touch ui dialogs it works as expected but i does not in page properties. Do you know if I need to do something special to use it into the page properties? Many Thanks!

Avatar

Level 4

Hi Surendra,

I am facing similar issue in AEM 6.3. Were you able to resolve this issue?