Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events
SOLVED

Targeted content doesn't work on Preview mode.

Avatar

Former Community Member

Hi,

I've been experimenting with AEM 6.1 personalization feature. I have created campaign-activity-experience and also segmentations.

I managed to author targeted content through targeting mode. It seems working on targeting mode, when I switch the activities, it'll show the targeted content for respective experience/audience.

However when I preview it on preview mode and use the user profiles from client context. the content doesn't change even though I change the profile match with the segmentation.

I can display those content by changing 'active campaign' and 'active experience' on client context though. But I don't think this is the correct way to preview the personalization.

 

Could you please let me know how to get it work on preview mode ? I tried to use the geometrixx sample site and it is also not working there.

 

Thanks.

1 Accepted Solution

Avatar

Correct answer by
Level 10

Hi there,

Thanks for reaching out to Adobe Community.

Please go through the below doc and try the hotfix and see if it helps in resolving the issue:

http://docs.adobe.com/docs/en/aem/6-1/release-notes/known-issues.html

Thanks!

View solution in original post

1 Reply

Avatar

Correct answer by
Level 10

Hi there,

Thanks for reaching out to Adobe Community.

Please go through the below doc and try the hotfix and see if it helps in resolving the issue:

http://docs.adobe.com/docs/en/aem/6-1/release-notes/known-issues.html

Thanks!