Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Style not appliying to text component

Avatar

Level 1

Hi all, I'd like to ask for your help with this, thanks in advance for checking it.

 

I have a text component on a template:

pixeldvx_0-1668617522833.png

I added a style to it:

pixeldvx_1-1668617552983.png

The style is showing in the style menu

pixeldvx_2-1668617586985.png

 

I select the style:

pixeldvx_3-1668617613076.png

 

But after selecting and enter in the Style menu again it appears unselected and the style never applies to the component.

 

I tried with other components adding fake styles and those apply, the issue happens only in the Text component.

 

Thanks for your support.

4 Replies

Avatar

Community Advisor

Hi @pixeldvx ,

Please ensure if the applied style's id matches as the style id in the policy.

Hope that helps!

Regards,

Santosh

Avatar

Level 1

Hi Santosh, thanks for your reply.

 

It matches, but the odd thing is that if I put, for example, in a List component the style "fake" in the policies and then I select it in the authoring it works, I mean, it applies the style and adds the class in the HTML to the component, but in this case for the text component I just can't select the style on the menu because it always switch to unselected automatically.

Avatar

Level 1

Thanks for your answer Manikumar, however I already checked that, and other documentation and the bug is only with the Text component, I guess is something not related to the style itself but to the component or the platform, I don't know and don't have any clue.