Highlighted

Sling Servlet 404 Not Found

sobhan_sahu

06-11-2017

Hi All,

I have a simple sling servlet under /bin/myservlet. when I am trying to hit the same from my JSP using AJAX call in console it is saying 404Not Found.

I am using AEM 6.3 version. Please help on the same.

Thanks,
Sobhan

Replies

Highlighted

sobhan_sahu

06-11-2017

Yes bundle is in active state and also servlet is getting resolved in the servlet resolver in ConfigMgr.

Only when I am trying to execute is in JSP via ajax call it is throwing 404 not found.

It is an AEM Forms JEE instance in JBoss.

Highlighted

sobhan_sahu

06-11-2017

    $.ajax({

         type: 'POST',   

         url:'/bin/getCount',

         data:'id='+ "1111",

         success: function(msg){

 

           var myMsg = "hello";

alert(myMsg);

         }

     });

Highlighted

sobhan_sahu

06-11-2017

What could be the possible reason of the kind of error m getting. Is that org.json dependency is a mandatory thing to be added. I think since I am not passing data in Json format that might not be the cause.

What else can I check to make this work.

Highlighted

smacdonald2008

06-11-2017

DId you test the servlet that i pointed you too? I want to know if this works in your environment. COuld be a issue with your environment.

Highlighted

mjb54261515

06-11-2017

Can you pls hit your servlet on aem server and look at the logs. make sure you pass correct query parameter when hititng the servlet

Generally it should show throw some error if servlet is not resolved or not registered correctly in servlet