Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events

Sling Servlet 404 Not Found

Avatar

Level 4

Hi All,

I have a simple sling servlet under /bin/myservlet. when I am trying to hit the same from my JSP using AJAX call in console it is saying 404Not Found.

I am using AEM 6.3 version. Please help on the same.

Thanks,
Sobhan

8 Replies

Avatar

Level 4

Yes bundle is in active state and also servlet is getting resolved in the servlet resolver in ConfigMgr.

Only when I am trying to execute is in JSP via ajax call it is throwing 404 not found.

It is an AEM Forms JEE instance in JBoss.

Avatar

Level 4

    $.ajax({

         type: 'POST',   

         url:'/bin/getCount',

         data:'id='+ "1111",

         success: function(msg){

 

           var myMsg = "hello";

alert(myMsg);

         }

     });

Avatar

Level 10

I just tested our SLing Post example and it worked. Try loading the 6.2 package here and testing -- Adobe Experience Manager Help | Submitting Adobe Experience Manager form data to Java Sling Servlets

You should get this result.

ASubmit.png

Avatar

Level 4

What could be the possible reason of the kind of error m getting. Is that org.json dependency is a mandatory thing to be added. I think since I am not passing data in Json format that might not be the cause.

What else can I check to make this work.

Avatar

Level 10

DId you test the servlet that i pointed you too? I want to know if this works in your environment. COuld be a issue with your environment.

Avatar

Level 6

Can you pls hit your servlet on aem server and look at the logs. make sure you pass correct query parameter when hititng the servlet

Generally it should show throw some error if servlet is not resolved or not registered correctly in servlet