Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Set file data store to NAS location 6.5

PhilBro
Level 2
Level 2

I'm setting up a 6.5 author locally to work out issue before I install on our linux server. I need to configure AEM to use a shared mounted drive for the location of its file data store. The data store will be shared with an offloader I'll be setting up next.

I've gone over this page Configuring node stores and data stores in AEM 6  and tried everything I can. When I set a different location the server either fails to start or it fails to use the new location. I start AEM using sudo to make sure it have permissions to do what ever it needs.

I've put these two files in the crx-quickstart/install dir with these settings commenting out various values for testing.

org.apache.jackrabbit.oak.plugins.blob.datastore.FileDataStore.config

#repository.home="crx-quickstart/repository/datastore"

path="/path/⁨user/Sites⁩/⁨AEM-Runtime⁩/⁨6.5⁩/datastore"

#minRecordLength="256"

org.apache.jackrabbit.oak.segment.SegmentNodeStoreService.config

#repository.home="crx-quickstart/repository"

#tarmk.size=I"256"

customBlobStore=B"true"

Any help figuring this our is appreciated.

1 Accepted Solution
aemmarc
Correct answer by
Employee
Employee

You need those FileDataStore configs in place from the first instantiation of AEM. You can't change it after-the-fact.

Unpack the JAR

Drop your configs in the crx-quickstart/install folder

Start AEM for the first time.

View solution in original post

2 Replies
aemmarc
Correct answer by
Employee
Employee

You need those FileDataStore configs in place from the first instantiation of AEM. You can't change it after-the-fact.

Unpack the JAR

Drop your configs in the crx-quickstart/install folder

Start AEM for the first time.

View solution in original post

PhilBro
Level 2
Level 2

That was the issue. I didn't see the instructions to unpack the jar in the docs. Thanks for the help.