Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Revert older version of CFP

Manh_Nguyen
Level 3
Level 3

Hi team,

I created a custom scaffolding for my project, it works fine until I installed CFP-14. One of the field is not showing value, when click save, it will store empty value to our database. I found that my custom scaffolding still working with previous version, can I know is there anyway to restore back?

Thanks.

Regards,

Manh

1 Accepted Solution
Andrew_Khoury
Correct answer by
Employee
Employee

Uninstalling SPs and CFPs is unsupported as Kunwar stated.  However, if you must revert it and do not have a backup.  Then try this:

1. Backup your AEM instance

2. Package up the /libs folder from another working environment and installing it to the post-CFP environment.  Note that you must also make sure to package and install the ACLs from the /libs folder as well (that can be done with the ACS Commons Query Packager).

3. Allow the packages to fully install and all bundles to restart, then restart AEM.

View solution in original post

7 Replies
Hemant_arora
Level 8
Level 8

Are you not able to uninstall it through packagemanager ?

Manh_Nguyen
Level 3
Level 3

Thanks for your reply.

Am I supposed to uninstall CFP? I read the release note and see that uninstalling CFP is not supported. I'm using AEM 6.2 SP1.

Adobe Experience Manager Help | Release Notes: AEM 6.2 Cumulative Fix Pack

Manh_Nguyen
Level 3
Level 3

Hi,

I got this error when trying to uninstall via package manager:

Error: javax.jcr.nodetype.ConstraintViolationException: OakConstraint0021: /home/users/A/As3xGtSMmEA1LxHNIA6R/.tokens/2018-05-22T15.29.45.872+08.00[[rep:Token]]: Mandatory property rep:token.key not found in a new node

I have no idea what this is... anyway to fix this?

Hemant_arora
Level 8
Level 8

Yes you would not be able to uninstall it. Repository contrainsts

try resolving the issue with your code keeping CFP14 installed.

Please raise a ticket with day care if reverting is possible. Let me also find a way . Hope you took backup of repo before uninstalling.

Kunwar
Employee
Employee

Uninstalling SPs and CFPs in not supported. Please perform a backup before you install Sps and CFPs in environment and later sanity test to check  if everything works well or not

Andrew_Khoury
Correct answer by
Employee
Employee

Uninstalling SPs and CFPs is unsupported as Kunwar stated.  However, if you must revert it and do not have a backup.  Then try this:

1. Backup your AEM instance

2. Package up the /libs folder from another working environment and installing it to the post-CFP environment.  Note that you must also make sure to package and install the ACLs from the /libs folder as well (that can be done with the ACS Commons Query Packager).

3. Allow the packages to fully install and all bundles to restart, then restart AEM.

View solution in original post

Manh_Nguyen
Level 3
Level 3

Thanks all for your reply,

I found a package that this version is not compatible with my custom scaffolding. It's possible to restore this package to previous version, without uninstalling the whole CFP-14 right?

com.adobe.granite.ui.content-0.8.362-CQ620-B0036.zip

Thanks,

Manh