Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Returning 403 status when go to my site from other sites.

Avatar

Level 2

Hi Everyone. I'm getting an issues When going to my site from other sites, It return a 403 status But everything is ok when I navigate from internal site.

luongpham1994_0-1653880106061.png

Thanks everyone.

 

4 Replies

Avatar

Community Advisor

Hi @luongpham1994 ,

 

If you're navigating this page URL from an external site then the page URL is facing an issue finding the relative domain to complete the URL. But as you mentioned it is working fine while redirecting internally it is because you are redirecting targeted pages from the same site domain. You should provide a complete path of that page while navigating from the external site/page.

Avatar

Level 2

Yes, I did provide the full url included "domain + path".
For ex: In google.com -> Open console tab -> enter location.href="my site", It's still returing 403 status except I enter the path to the address bar directly

Avatar

Community Advisor

Is there any rewrite rules in place?

Check network calls on click of link from external site.

Share the error log if possible.

Avatar

Community Advisor

Hi @luongpham1994 

Do you see any bundle is not in Active state(related to that site)? you must have something in error.log please check and try to fix or paste trace here.

Regards,
Santosh