Restricting access to Workflow Models for specific groups in AEM 6.4

Avatar

Avatar
Boost 1
Level 2
farahz913310
Level 2

Like

1 like

Total Posts

20 posts

Correct reply

0 solutions
Top badges earned
Boost 1
Validate 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Boost 1
Level 2
farahz913310
Level 2

Like

1 like

Total Posts

20 posts

Correct reply

0 solutions
Top badges earned
Boost 1
Validate 1
Give Back 5
Give Back 3
Give Back
View profile
farahz913310
Level 2

18-09-2019

Hi all,

I have a requirement to restrict access to all OOTB workflows for specific group in AEM 6.4.

Hence all the user of that group should only see Specific Workflow in "Start Workflow" List.

I tried doing it using  Useradmin but I cant see all OOTB workflows  under var/workflow/models node in useradmin but  I can see all the node in CRX.

Can anyone guide me on the same.

Thanks.

Kind Reagrds,

Farah

Replies

Avatar

Avatar
Coach
Employee
jbrar
Employee

Likes

389 likes

Total Posts

869 posts

Correct reply

283 solutions
Top badges earned
Coach
Establish
Give Back 50
Give Back 5
Give Back 3
View profile

Avatar
Coach
Employee
jbrar
Employee

Likes

389 likes

Total Posts

869 posts

Correct reply

283 solutions
Top badges earned
Coach
Establish
Give Back 50
Give Back 5
Give Back 3
View profile
jbrar
Employee

18-09-2019

I quickly tried this on my side and workflows are read from the locations below:

/conf/global/settings/workflow/models

/var/workflow/models

So, you need to remove the access for workflow from both locations. It works fine on my side.

Avatar

Avatar
Give Back 50
Employee
Vish_dhaliwal
Employee

Likes

189 likes

Total Posts

356 posts

Correct reply

123 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile

Avatar
Give Back 50
Employee
Vish_dhaliwal
Employee

Likes

189 likes

Total Posts

356 posts

Correct reply

123 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile
Vish_dhaliwal
Employee

18-09-2019

Hey Farah,

Also, check this similar post: https://forums.adobe.com/thread/2603702#10980636

Avatar

Avatar
Boost 1
Level 2
farahz913310
Level 2

Like

1 like

Total Posts

20 posts

Correct reply

0 solutions
Top badges earned
Boost 1
Validate 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Boost 1
Level 2
farahz913310
Level 2

Like

1 like

Total Posts

20 posts

Correct reply

0 solutions
Top badges earned
Boost 1
Validate 1
Give Back 5
Give Back 3
Give Back
View profile
farahz913310
Level 2

18-09-2019

I  tried the approach mentioned in this post but

Adding the system tag hides the workflow model for all users.

Is there a way to only hide the workflow models for certain groups or a user?

As mentioned in post I also  tried adding ACL on  the var/workflows/model node but I am not able to add ACL on individual model node.

Avatar

Avatar
Give Back 50
Employee
berliant
Employee

Likes

207 likes

Total Posts

315 posts

Correct reply

98 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile

Avatar
Give Back 50
Employee
berliant
Employee

Likes

207 likes

Total Posts

315 posts

Correct reply

98 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile
berliant
Employee

18-09-2019

You can use CRXDe to add a deny ACL to an individual OOTB workflow model:

1834311_pastedImage_0.png

Avatar

Avatar
Coach
Employee
jbrar
Employee

Likes

389 likes

Total Posts

869 posts

Correct reply

283 solutions
Top badges earned
Coach
Establish
Give Back 50
Give Back 5
Give Back 3
View profile

Avatar
Coach
Employee
jbrar
Employee

Likes

389 likes

Total Posts

869 posts

Correct reply

283 solutions
Top badges earned
Coach
Establish
Give Back 50
Give Back 5
Give Back 3
View profile
jbrar
Employee

18-09-2019

Check if you have access to edit group permissions. Basically, you need to open the group in the useradmin console, go to permissions tab and allow/deny the access. Try logging in with "admin" user to perform these activities.

Screen Shot 2019-09-18 at 9.35.13 AM.png

Avatar

Avatar
Boost 1
Level 2
farahz913310
Level 2

Like

1 like

Total Posts

20 posts

Correct reply

0 solutions
Top badges earned
Boost 1
Validate 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Boost 1
Level 2
farahz913310
Level 2

Like

1 like

Total Posts

20 posts

Correct reply

0 solutions
Top badges earned
Boost 1
Validate 1
Give Back 5
Give Back 3
Give Back
View profile
farahz913310
Level 2

18-09-2019

Yeah I am tring to do the same  but somehow in 6.4 whenever I am trying to add to individual node I am getting internal server error  on clicking on +.

Are you able to add when you click on +

Avatar

Avatar
Give Back 5
Employee
SonDang
Employee

Likes

17 likes

Total Posts

43 posts

Correct reply

9 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 10
Give Back
Boost 5
View profile

Avatar
Give Back 5
Employee
SonDang
Employee

Likes

17 likes

Total Posts

43 posts

Correct reply

9 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 10
Give Back
Boost 5
View profile
SonDang
Employee

18-09-2019

Are you using the admin account to edit the permission? Or are you using a different user? If you are using a different user, which group does the user belong to?

Avatar

Avatar
Boost 1
Level 2
farahz913310
Level 2

Like

1 like

Total Posts

20 posts

Correct reply

0 solutions
Top badges earned
Boost 1
Validate 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Boost 1
Level 2
farahz913310
Level 2

Like

1 like

Total Posts

20 posts

Correct reply

0 solutions
Top badges earned
Boost 1
Validate 1
Give Back 5
Give Back 3
Give Back
View profile
farahz913310
Level 2

18-09-2019

Yes I am using the admin account but still it doesnt work

Avatar

Avatar
Boost 1
Level 2
farahz913310
Level 2

Like

1 like

Total Posts

20 posts

Correct reply

0 solutions
Top badges earned
Boost 1
Validate 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Boost 1
Level 2
farahz913310
Level 2

Like

1 like

Total Posts

20 posts

Correct reply

0 solutions
Top badges earned
Boost 1
Validate 1
Give Back 5
Give Back 3
Give Back
View profile
farahz913310
Level 2

18-09-2019

I am not able to see OOTB workflows under conf node.They are available under var/workflow/model. But in useradmin I cant see them .