Expand my Community achievements bar.

Applications for the 2024-2025 Adobe Experience Manager Champion Program are open!
SOLVED

Resource not found

Avatar

Level 1

Hi,

 I am having issue with both the authoring and publishing instance while serving content, i have a product page for which i am passing in the material id the material id has forward slash in it ,so the request goes in as

/content/product/MD102LL%2FA

but sling is resolving it to 

/content/product/MD102LL/A/ and not returning the page.

Is there any setting on the server that i need to turn on .

1 Accepted Solution

Avatar

Correct answer by
Level 1

was able to fix this issue by adding allow encoded slashes directive in apache httpd.conf file.Nothing to do with AEM. 

View solution in original post

3 Replies

Avatar

Employee Advisor

Hi,

As Scott already wrote, the escaped forward slash might be the root cause. Can you replace it by a different character at least in the page (not necessarily the page title)? While there's nothing wrong to have "%2F" in a JCR name, Sling does not know, that in this special case it does not have un-escape it to "/".

kind regards,
Jörg

Avatar

Level 10

The forward slash in the ID parameter is confusing AEM. You can look into using Sling URL mapping:

http://docs.adobe.com/content/docs/en/cq/5-6-1/deploying/resource_mapping.html

Avatar

Correct answer by
Level 1

was able to fix this issue by adding allow encoded slashes directive in apache httpd.conf file.Nothing to do with AEM.