Pattern Detector: non.backwards.compatible.code

jag01

07-04-2020

Hi All,

 

I'm working on aem 6.3 to 6.5 in place upgrade activity. After running pattern detector I have found the below issue:

 

jag01_0-1586267538595.png

 

Can anyone help me resolve this.

 

Thanks

Accepted Solutions (1)

Accepted Solutions (1)

Theo_Pendle

MVP

07-04-2020

Hello,

This means that the bundle mentioned has a dependency which will no longer be available when you upgrade to 6.5, so it won't work anymore.

The screenshot is very small but if I'm not mistaken you got this warning for a bundle that is part ACS Commons, correct? What version are you using?

If you look at the compatibility matrix, you will see that you need to be on version 4.x.x minimum for AEM 6.5 (which is also compatible with AEM 6.3). If you update ACS Commons to 4.5.0, the issue should be fixed 🙂

Answers (0)