Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Page navigation links on publisher are not having /content/sitename prepended

manu-gupta
Level 3
Level 3

Hi members,

Environment AEM6.5.8

Server: Linux

We are running into one issue with site package on AEM 6.5.8 Publisher server where site is created, added multiple pages under it. they are residing under

/content/aemportal/search.html, /content/aemportal/listing.html etc

The pages are working fine on Author Instance and getting desied results as expected but when we are publishing to Publisher server then we are experiencing the pages are not giving full path in url when navigating between pages or during form submit for search

Pages do exist at required path as in Author

but urls are getting created like localhost:4503/seach.html instead of localhost:4503/content/aemportal/search.html

 

We have checked page properties but neither we have ALIAS set nor we are using vanity urls.

 

 

Any advice or session will be helpful from you to debug.

 

 

1 Accepted Solution
Dipti_Chauhan
Correct answer by
Community Advisor
Community Advisor

Hi @manu-gupta 

  Please check you resource resolver properties on publish <org.apache.sling.jcr.resource.internal.JcrResourceResolverFactoryImpl>   or check /etc/map/http

 

May be you have added resource mapping for /content/aemportal

 

Thanks

DIpti

View solution in original post

4 Replies
kishorekumar14
Level 8
Level 8

hi @manu-gupta ,

 

Could you please check if there is any change done in Apache sling resource resolver factory (org.apache.sling.jcr.resource.internal.JcrResourceResolverFactoryImpl) OSGI config of publisher run mode.

asutosh_jena
Community Advisor
Community Advisor

Hi @manu-gupta 

 

Please check if you have defined any resource reolver mapping for publish runmode with the property as "/content/aemportal/:/" in org.apache.sling.jcr.resource.internal.JcrResourceResolverFactoryImpl configuration.

or

if you have defined any sling mappings in /etc/maps for your publish instance.

 

You will have more info here:

https://techforum.medium.com/configure-sling-mapping-for-resource-resolution-in-adobe-experience-man...

 

Hope this helps!

Thanks

Dipti_Chauhan
Correct answer by
Community Advisor
Community Advisor

Hi @manu-gupta 

  Please check you resource resolver properties on publish <org.apache.sling.jcr.resource.internal.JcrResourceResolverFactoryImpl>   or check /etc/map/http

 

May be you have added resource mapping for /content/aemportal

 

Thanks

DIpti

View solution in original post

manu-gupta
Level 3
Level 3

thanks all everyone was right it was vanity url was still holding value within JcrResourceResolverFactoryImpl configuration despite I had removed vanity urls from all page properties.

 

Appreciate your guidance and help.

 

Manu