Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

OOTB Sales Force Search Component in AEM is not working as expected

trisandhyan5727
Level 1
Level 1

I am trying to Integrate AEM with Sales Force, conenction is successful.

When i use OOTB Sales Force Search Component, dialog of the component is not working as expected.

Operator and Values fields are not allowed to edit. Could you please provide any ideas over it. I have tried this component in 6.5 as well 6.1 but the same behavior. 

 

trisandhyan5727_1-1594116317280.png

 

 

 

1 Accepted Solution
Vaibhavi
Correct answer by
Community Advisor
Community Advisor

Hi @trisandhyan5727 

When you try editing the component, check the console (using developer tool ) for any errors? 

 

On the page where you have added the  Salesforce search component, please do navigate to page properties and map salesforce configuration in cloud config tab.

You should be able to use the feature then.

 

salesforce.PNG

 

Please check the below document for more details

https://helpx.adobe.com/in/experience-manager/6-3/sites/administering/using/salesforce.html

 

View solution in original post

5 Replies
Vaibhavi
Correct answer by
Community Advisor
Community Advisor

Hi @trisandhyan5727 

When you try editing the component, check the console (using developer tool ) for any errors? 

 

On the page where you have added the  Salesforce search component, please do navigate to page properties and map salesforce configuration in cloud config tab.

You should be able to use the feature then.

 

salesforce.PNG

 

Please check the below document for more details

https://helpx.adobe.com/in/experience-manager/6-3/sites/administering/using/salesforce.html

 

View solution in original post

trisandhyan5727
Level 1
Level 1
Hi @Vaibhavi, I have checked the error in the console and looks like issue with the namespace-
trisandhyan5727
Level 1
Level 1
Uncaught TypeError: Cannot read property 'namespace' of undefined...CQ.Ext.namespace("CQ.salesforce");
Vaibhavi
Community Advisor
Community Advisor

Hi @trisandhyan5727 ,

 

On the page where you have added the  Salesforce search component, please do navigate to page properties and map salesforce configuration in cloud config tab.

You should be able to use the feature then.

 

salesforce.PNG

 

Please check the below document for more details

https://helpx.adobe.com/in/experience-manager/6-3/sites/administering/using/salesforce.html

 

trisandhyan5727
Level 1
Level 1
Hi @Vaibhavi,Added it in page properties but the component is not working as expected,as showi in the original post. Operator field functionality is not as expected