Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

[AEM Gems Webinar] Accelerating Experience Manager as a Cloud Service development with Rapid Development Environments

On selecting the Rich text editor(RTE)- special characters cursor is not moving forwards.

Avatar

Level 2

I am trying to select the special characters from the RTE but when I select the special character the cursor is not moving forward because of which the next character is added in front of first character. 

In the below screenshot, first I have selected "£" next "—" and then "©".
So it should show up as "£—©" but since the cursor is not moving it is displayed as "©—£".


Below is the screenshot of the issue.

Junnu_ravali_0-1636719472679.png

 


Can someone please help me how to resolve the issue.

4 Replies

Avatar

Community Advisor

Hi @Junnu_ravali 
Can you please confirm what AEM version you are using and whether the richtext component is based on core component?

Please try extending from /apps/core/wcm/components/text/v2/text 

Also check out - https://experienceleague.adobe.com/docs/experience-manager-65/administering/operations/rich-text-edi...

 

Thanks

Avatar

Level 2

Hi @Shubham_borole 
I am using AEM 6.5 and the sling:resourceType is  "cq/gui/components/authoring/dialog/richtext" and its a custom component.

Avatar

Employee

Can also be seen in any Text component in AEM 6.5 using latest (2.17.14) WCM Core text component (/apps/core/wcm/components/text/v2/text).

It's a bug - SITES-1256