Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

NullPointerException for "Update DAM Asset" workflow and Could not start custom workflows

Avatar

Avatar
Validate 10
Level 4
sreenu539
Level 4

Likes

7 likes

Total Posts

158 posts

Correct Reply

1 solution
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 20
View profile

Avatar
Validate 10
Level 4
sreenu539
Level 4

Likes

7 likes

Total Posts

158 posts

Correct Reply

1 solution
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 20
View profile
sreenu539
Level 4

13-12-2017

AEM 6.3:

I tried to start out of the box "Update DAM Asset" workflow and it seemed to go fine until I saw following in the logs.

3.12.2017 16:14:05.573 *ERROR* [sling-threadpool-aade99ba-9e87-41c1-bb3f-c30f2b2d3783-(apache-sling-job-thread-pool)-727-Granite Transient Workflow Queue(com/adobe/granite/workflow/transient/job/etc/workflow/models/dam/update_asset/jcr_content/model)] com.adobe.granite.workflow.core.job.JobHandler Error processing workflow job

java.lang.NullPointerException: null

at com.adobe.granite.workflow.core.jcr.WorkflowManager.getSimpleModelId(WorkflowManager.java:1088)

at com.adobe.granite.workflow.core.jcr.WorkflowManager.createWorkflowInstance(WorkflowManager.java:298)

at com.adobe.granite.workflow.core.job.JobHandler.process(JobHandler.java:159)

at org.apache.sling.event.impl.jobs.JobConsumerManager$JobConsumerWrapper.process(JobConsumerManager.java:500)

at org.apache.sling.event.impl.jobs.queues.JobQueueImpl.startJob(JobQueueImpl.java:291)

at org.apache.sling.event.impl.jobs.queues.JobQueueImpl.access$100(JobQueueImpl.java:58)

at org.apache.sling.event.impl.jobs.queues.JobQueueImpl$1.run(JobQueueImpl.java:227)

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)

at java.lang.Thread.run(Thread.java:748)

13.12.2017 16:14:07.601 *ERROR* [sling-threadpool-aade99ba-9e87-41c1-bb3f-c30f2b2d3783-(apache-sling-job-thread-pool)-728-Granite Transient Workflow Queue(com/adobe/granite/workflow/transient/job/etc/workflow/models/dam/update_asset/jcr_content/model)] com.adobe.granite.workflow.core.job.JobHandler Error processing workflow job

java.lang.NullPointerException: null

at com.adobe.granite.workflow.core.jcr.WorkflowManager.getSimpleModelId(WorkflowManager.java:1088)

at com.adobe.granite.workflow.core.jcr.WorkflowManager.createWorkflowInstance(WorkflowManager.java:298)

at com.adobe.granite.workflow.core.job.JobHandler.process(JobHandler.java:159)

at org.apache.sling.event.impl.jobs.JobConsumerManager$JobConsumerWrapper.process(JobConsumerManager.java:500)

at org.apache.sling.event.impl.jobs.queues.JobQueueImpl.startJob(JobQueueImpl.java:291)

at org.apache.sling.event.impl.jobs.queues.JobQueueImpl.access$100(JobQueueImpl.java:58)

at org.apache.sling.event.impl.jobs.queues.JobQueueImpl$1.run(JobQueueImpl.java:227)

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)

at java.lang.Thread.run(Thread.java:748)

Custom application workflows are giving "Could not start workflow" and workflows are not even starting.

I logged in as "adminstrator" and has all the permissions on workflow nodes.

Thanks,

Sri

Replies

Avatar

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

470 likes

Total Posts

1,039 posts

Correct Reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

470 likes

Total Posts

1,039 posts

Correct Reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile
Veena_Vikram
MVP

15-12-2017

Are you seeing this error for any particular set of Assets ? When you start  your custom application workflows , what exact error are you getting in the logs ? Is it logging something ?

Which AEM version are you using?

Avatar

Avatar
Validate 10
Level 4
sreenu539
Level 4

Likes

7 likes

Total Posts

158 posts

Correct Reply

1 solution
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 20
View profile

Avatar
Validate 10
Level 4
sreenu539
Level 4

Likes

7 likes

Total Posts

158 posts

Correct Reply

1 solution
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 20
View profile
sreenu539
Level 4

15-12-2017

AEM 6.3 with CFP.

Custom application workflows - "Could not start workflow" alert coming and workflow never triggered.

OTB workflow "Update DAM Asset" throwing above exception in logs on all dam assets.