Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Not able to use synthetic workflow on deletion-workflow using ACS bulkworkflow manager

Morten_Thuesen
Level 2
Level 2

Hi everyone,

I'm having some issues with getting a workflow to execute properly using ACS Bulk Workflower manager when selecting "Synthetic Workflow" (I've previously been taught, that this mode is preferable over the standard AEM workflow). The workflow should delete assets, but doesn't when I use "Synthetic Workflow".

1859437_pastedImage_0.png

I've created a workflow in AEM using OOTB functionality (note: I also couldn't get it to work with the step "Delete Asset" - I had to choose "Delete Node" for it to work). The workflow consists of 4 steps:

1859438_pastedImage_1.png

I've tried to use it on a single asset in AEM using create -> workflow, and then it works. It also works, when I use the standard AEM workflow in the Bulk Workflow Manager, even though Bulk workflow manager seems to freeze when executing it. But when I select the synthetic workflow, it executes based on the SQL I provide, but doesn't delete anything.

Have any of you experienced the same issue?

Regards,

Morten

2 Replies
berliant
Employee
Employee

A syntectic workflow is a part of the ACS Common tool. There was some issue in earlier versions of "Synthetic Workflow". Make sure that you are using the most recent ACS that is suitable for your version of AEM.

Morten_Thuesen
Level 2
Level 2

Hi berliant,

I've just checked with our AEM partner, and we have the lastest ACS-commons package installed. So it is unfortunately not solved by this.

Do you have any other ideas on what I could try to do?

Regards,

Morten