Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Nissan - High CPU Usage Issue

hemalathab
Level 1
Level 1

Hi Adobe Team,

I'm  working for Nissan-USA. We have Premium Membership for AEM .We are facing High CPU Usage 98% frequently with our Publish Instances.

Tried to analyze using logs and Thread Dumps, but we are not seeing any of our service related. All related to AEM application logs and Threads are waiting state.

Below is the Issue Description:

1.We have Production Environment where we configured 4 Publish Instances and 2 Author Instances.

2.We configured AEM on App nodes.

3.Frequently ,we are Experiencing High CPU usage Load i.e CPU usage is Hitting 98% on one of the Publish instances and remaining for 10 hours nearly.

Also, at the same time we are not seeing any load on other Publish Instances.

4.We verified the Dispatcher level configurations and logs also, we are seeing normal request processing and there are no errors in Error logs.

Please raise a Support Ticket and let us know the Solution. We can share all the thread dumps and Logs which we captured during this issue. Adobe Experience Manager

2 Replies
tanyakapila
Employee
Employee

Hi hemalathab ,

Please log a ticket at https://daycare.day.com/home.html . If you do not have an account , please drop a mail at cuscare@adobe.com.

vengadeshs86143
Level 3
Level 3

CPU might be due to alot of replication happening from Author to publish while many of the request hitting your publish instance as well.

In some cases i saw 404 (on a highly traffic page) may also end up hitting publisher.

A good starter to debug this issue will be request log and thread dumps...Try to find the slow requests from request log.

Check for slow queries and see if you create oak index for those queries taking more time.