Highlighted

New Folders and Files are not showing up under /content/dam in Touch UI

peterw13024062

15-11-2017

Encountered an issue where all of sudden newly created files and folders are not showing up in AEM 6.3 Touch UI content dam folder, it's showing properly in classic UI and can see them in CRX as well.

Also,Created folder of both types sling:OrderedFolder and sling:Folder  but still not showing up in list,column and card view.

Looking for a solution as what can be possible root cause.

Replies

Highlighted

mjb54261515

15-11-2017

Hi Peter,

I just created couple of test folders (sling:Folder) and uploaded images in it. I dont see any issue in Touch UI and i also tested this on different view. It works fine.

Check flowing snaps

1349613_pastedImage_1.png

1349614_pastedImage_2.png

Are you trying to generate folders and images programmatically  by chance? other than that I don't see an issue.


~Manoj

Highlighted

peterw13024062

15-11-2017

Hi Manoj,

I created folders in similar way and uploaded images but after creation of 12 folders not able to view and access new folders i.e 13 th folder and so on in Touch UI but can view then in classic UI and in CRXDE.

Highlighted

kautuk_sahni

Community Manager

16-11-2017

Do you see some error in browser and error.log? Can you reproduce it with fresh instance?

~kautuk

Highlighted

mjb54261515

16-11-2017

Oh OK. I just created 18 test folders(sling:Folder) and images in it as shown below. It's correctly showing up in Touch UI.

1350052_pastedImage_0.png

There is no issue in OOB dam folder creation in dam.

I remember having similar Touch UI issue in AEM 6.1 after debugging a lot we found out one of the folder's JCR node was corrupted or did not exits. This looks like similar issue. pls check/compare all your child folder and its jcr node properties with perfectly working folder properties,

Hope that helps.

~Manoj