Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

My website styles and header and footer experience fragment is not coming in incognito browser

dipu2
Level 3
Level 3

Dear All,

I have setup my local AEM author , publish and dispatcher environment. 

But my dispatcher content is coming fine in Chrome browser , as shown below.

dipu2_0-1599056248827.png

 

It is not coming fine in Incognito browser. My header and footer experience fragment is not coming fine and also my style is not coming fine , as shown below.

 

dipu2_2-1599056620518.png

 

Can anybody faced like this issue?

1 Accepted Solution
dipu2
Correct answer by
Level 3
Level 3

Dear All,

 

This issue is fixed.

 

I have cleared dispatcher cache and published the experience fragments once again. Now it is coming fine in all browser.

View solution in original post

3 Replies
Shashi_Mulugu
Community Advisor
Community Advisor

@dipu2 Can you please check permissions for anonymous users? If it has access to /content/experience-fragments/ and /conf/ paths.. A minimum of read permissions need to be present.

 

Also how are you including those experience fragments on to the page? Is it via sly include or via SDI? Please explain.

dipu2
Correct answer by
Level 3
Level 3

Dear All,

 

This issue is fixed.

 

I have cleared dispatcher cache and published the experience fragments once again. Now it is coming fine in all browser.

View solution in original post

kautuk_sahni
Community Manager
Community Manager
Thank you for sharing the answer with the community. This would help in posterity.