Highlighted

My Targeting Configured Components are not displayed Viewing as Published

caio_moreira

20-09-2019

Hello everyone,

When I configure Targeting on a component its content is not being viewed as published. I am using AEM 6.5.

I have an experiment fragment and text component with Targeting set up:evidence1.PNG

When I see the page as published, it presents the following error:

evidence2.PNG

[AT: Rendering mbox failed target-global-mbox : {status: "error", error: "unknown client code: ifactsolamericasptrsd"}]

This is my client code and I used it in my Cloud Service Target configuration:

evidence3.PNG

Does anyone have a similar problem?

Do you think there is any configuration that I did not do?

Thanks,

Regards

Replies

Highlighted

jbrar

Employee

20-09-2019

Can you check if you have applied the target configuration to the site?

Screen Shot 2019-09-20 at 10.46.14 AM.png

Also, check if you have published the target configuration to publish instance.

Highlighted

caio_moreira

20-09-2019

Hello, thanks for replying.

I applied Target as Cloud Service Configuration to the root of the site. And also for my experiences fragments.

About the experience fragments I'm using in targeting at page, they are published and exported to my Target instance. But they were exported as HTML Offer (I expected them to be exported as Experience Fragments Type, but I believe this is not the cause of the problem).

evidence4.PNG

My problem still persists, do you believe that may be what I show you? Do you know why my experience fragments were exported as HTML Offer and not as Experience Fragment?

Thanks you for your support,

Regards

Highlighted

berliant

Employee

21-09-2019

It seems that you are using new IMS to Target connection. The reason that XF exported as an HTML is a known limitation of the current implementation of IMS->Adobe IO -> Target connection. In order to be able to export to Target as XF you need to use an old (deprecated) way by employing a Target Classic account.

Highlighted

caio_moreira

23-09-2019

Hi Berliant.

Thank you for your support.

I was able to solve the problems of Experience Fragment being exported as HTML Offer requesting access for credential integration. However, my initial problem persists, the contents of my configured targeting components don't appear when I see the page as published, even though there are no errors in the console.

Now my exported activity is from Adobe Experience Manager source (correctly) and my AEM exported fragments are Experience Fragments type in Target (correctly). As you can see below:

evidence1.PNG

evidence2.PNG

But my content is not yet displayed when I view it as published...

evidence3.PNG

evidence4.PNG

Does anyone have a similar problem, berliant​ ?

Thanks,

Regards

Highlighted

sunjot16

Employee

23-09-2019

If you go to http://<host>:<port>/system/console/components on your publish, try stopping/starting the TargetedContentMangerImpl component manually.

Highlighted

josuev40522873

08-11-2019

Hello caio.moreira

I wonder if you can please help me:

1. How do you fix the specific issue with the clientcode error?

2. Were you able to fix the issue with the published version of the page?

Thanks in advance,

Highlighted

nicolec5631060

16-01-2020

Is anyone else facing similar issue? I am on aem 6.5 and i do not see the targeted result. I am using the IMS approach

Highlighted

berliant

Employee

17-01-2020

When exporting XF to a Target, you need to configure  AEM Externalizer at /system/console/configMgr/com.day.cq.commons.impl.ExternalizerImpl

Exported XF will reside on AEM Publish and it has to be accessible via a correct URL

Highlighted

Rishi_Bhargava

27-03-2020

AT: Rendering mbox failed target-global-mbox

 

Object { status: "error", error: "unknown client code: adobeapac37" }

I am using AEM + Target + IMS + IO with AEM 6.5.3