Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events
SOLVED

Multi field rich text not allowing fragment reference

Avatar

Level 1

Why can't I embed a fragment reference in a multi-line text field when rendered as multi-field

I'm able to embed a fragment reference when the multi line text is rendered as "text area." Why allow me the ability to select "Allow fragment reference" if I cannot actually utilize this when "multi field" is selected?

Screen Shot 2023-01-31 at 4.07.41 PM.png

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Hi @Mel-11 ,

 

You can enable in-line references  to other Content Fragments by checking the Allow Fragment Reference and configuring the Allowed Content Fragment Models in Multi-line text data type as shown below:

 

ChitraMadan_0-1675203149508.jpeg

Can you please check if this option is available when you're rendering it as "multi field", while defining the model?

 

Also, please refer to below articles for more details:

https://experienceleague.adobe.com/docs/experience-manager-learn/getting-started-with-aem-headless/h...

 

Hope this helps!!

 

Thanks,

Chitra

View solution in original post

3 Replies

Avatar

Correct answer by
Community Advisor

Hi @Mel-11 ,

 

You can enable in-line references  to other Content Fragments by checking the Allow Fragment Reference and configuring the Allowed Content Fragment Models in Multi-line text data type as shown below:

 

ChitraMadan_0-1675203149508.jpeg

Can you please check if this option is available when you're rendering it as "multi field", while defining the model?

 

Also, please refer to below articles for more details:

https://experienceleague.adobe.com/docs/experience-manager-learn/getting-started-with-aem-headless/h...

 

Hope this helps!!

 

Thanks,

Chitra

Avatar

Level 1

Hi @ChitraMadan , 

Thanks for your response. I'm struggling to insert a fragment specifically when I have "multifield" selected in the top field (rendered as). The screenshot below shows that I've selected "Allow fragment reference" and have selected multiple fragment models to select from. 

Screen Shot 2023-02-01 at 9.44.41 AM.png

 

 But on the authoring side, I don't see the icon to actually insert a content fragment. 

Screen Shot 2023-01-31 at 4.02.22 PM.png

Is this a bug? Or, is this ability not possible when when "multi field" is selected?

 

Avatar

Community Advisor

Hi @Mel-11 , 

 

May be try to replicate the same thing on we.retail to check if this is the product bug.

 

Thanks,

Chitra