MSM - Activation done on Content modification

Avatar

Avatar
Level 1
praveene2538348
Level 1

Likes

0 likes

Total Posts

4 posts

Correct reply

0 solutions
View profile

Avatar
Level 1
praveene2538348
Level 1

Likes

0 likes

Total Posts

4 posts

Correct reply

0 solutions
View profile
praveene2538348
Level 1

26-03-2019

Hi There,

Currently, I am facing an issue in MSM service on content activation. Any help would be helpful.

Issue - The live-copy contents are getting published automatically whenever there is a change in BluePrint source content without any manual activation. I have given the trigger as 'publish'. But it triggers on any content modification itself. No customization has been done so far. As of now, I am using the core service.

Expectation: The live-copy content should be activated only when there is a publish trigger in the source blueprint page.

Version: 6.2

1719049_pastedImage_0.png

Thanks.

Replies

Avatar

Avatar
Boost 250
MVP
Gaurav-Behl
MVP

Likes

250 likes

Total Posts

1,147 posts

Correct reply

283 solutions
Top badges earned
Boost 250
Establish
Give back 300
Give Back 50
Give Back 5
View profile

Avatar
Boost 250
MVP
Gaurav-Behl
MVP

Likes

250 likes

Total Posts

1,147 posts

Correct reply

283 solutions
Top badges earned
Boost 250
Establish
Give back 300
Give Back 50
Give Back 5
View profile
Gaurav-Behl
MVP

26-03-2019

Path to check rollout configs as mentioned by Vishu:

/content/<we-retail or your project_root>/us/en/jcr:content/cq:LiveSyncConfig

cq:rolloutConfigs

String[]

/apps/msm/wcm/rolloutconfigs/pushondelete, /libs/msm/wcm/rolloutconfigs/default

Avatar

Avatar
Give Back 50
Employee
Vish_dhaliwal
Employee

Likes

189 likes

Total Posts

356 posts

Correct reply

123 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile

Avatar
Give Back 50
Employee
Vish_dhaliwal
Employee

Likes

189 likes

Total Posts

356 posts

Correct reply

123 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile
Vish_dhaliwal
Employee

26-03-2019

Hello Praveen,

Can you try with OOTB "Activate on Blueprint activation" config and see how it goes?

Regards,

Vishu

Avatar

Avatar
Level 1
praveene2538348
Level 1

Likes

0 likes

Total Posts

4 posts

Correct reply

0 solutions
View profile

Avatar
Level 1
praveene2538348
Level 1

Likes

0 likes

Total Posts

4 posts

Correct reply

0 solutions
View profile
praveene2538348
Level 1

26-03-2019

Hi Vishu,

Currently, I am using all the OOTB rollout configs. Not added any of my custom ones. Please find the config screenshot.

The OOTB 'Activate on blueprint activation' is causing the issue. It activates the live copy pages without any publish trigger. I have checked the cq:trigger for 'Activate on blueprint' roll config. It looks correct and mentioned as 'publish'.

AEM MSM   Blueprint Control Center.png

Thanks.

Avatar

Avatar
Give Back 50
Employee
Vish_dhaliwal
Employee

Likes

189 likes

Total Posts

356 posts

Correct reply

123 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile

Avatar
Give Back 50
Employee
Vish_dhaliwal
Employee

Likes

189 likes

Total Posts

356 posts

Correct reply

123 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile
Vish_dhaliwal
Employee

26-03-2019

According to this, the content from blueprint (Source) will get copied to live copy automatically when there are any modifications in source and livecopy will be activated/deactivated only when the source is activated.

But in your case, the live copy is getting activated without the activation of the blueprint. Is my understanding correct?

Avatar

Avatar
Level 1
praveene2538348
Level 1

Likes

0 likes

Total Posts

4 posts

Correct reply

0 solutions
View profile

Avatar
Level 1
praveene2538348
Level 1

Likes

0 likes

Total Posts

4 posts

Correct reply

0 solutions
View profile
praveene2538348
Level 1

26-03-2019

yes. you are right. It is not working as expected.

The activation is happening without the activation of the blueprint pages.

Avatar

Avatar
Give Back 50
Employee
Vish_dhaliwal
Employee

Likes

189 likes

Total Posts

356 posts

Correct reply

123 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile

Avatar
Give Back 50
Employee
Vish_dhaliwal
Employee

Likes

189 likes

Total Posts

356 posts

Correct reply

123 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile
Vish_dhaliwal
Employee

26-03-2019

Thanks for the clarification.

We would need debug logs and more information in order to investigate this issue further. Please open a daycare ticket [1] and share the error and debug logs.

For Debug level MSM log:

- Go to http://host:port/system/console/slinglog

- Click Add New Logger

- Set it with this configuration:

Log Level: Debug

Log File: logs/msm.log

Loggers:

  1. com.day.cq.wcm.msm.impl.MSMEventProcessor
  2. com.day.cq.wcm.msm.impl.actions.ActionManagerImpl
  3. com.day.cq.wcm.msm.impl.actions.AccessControlActionFactory

[1] https://daycare.day.com/home.html

Avatar

Avatar
Boost 250
MVP
Gaurav-Behl
MVP

Likes

250 likes

Total Posts

1,147 posts

Correct reply

283 solutions
Top badges earned
Boost 250
Establish
Give back 300
Give Back 50
Give Back 5
View profile

Avatar
Boost 250
MVP
Gaurav-Behl
MVP

Likes

250 likes

Total Posts

1,147 posts

Correct reply

283 solutions
Top badges earned
Boost 250
Establish
Give back 300
Give Back 50
Give Back 5
View profile
Gaurav-Behl
MVP

26-03-2019

Avatar

Avatar
Coach
Employee
Jörg_Hoh
Employee

Likes

1,134 likes

Total Posts

3,161 posts

Correct reply

1,079 solutions
Top badges earned
Coach
Give back 600
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Coach
Employee
Jörg_Hoh
Employee

Likes

1,134 likes

Total Posts

3,161 posts

Correct reply

1,079 solutions
Top badges earned
Coach
Give back 600
Ignite 5
Ignite 3
Ignite 1
View profile
Jörg_Hoh
Employee

26-03-2019

Not directly related to your problem: "Push on Modify" is likely to overwhelm AEM instances, and I would not recommend it when the number of livecopies exceeds a small number.

Jörg

Avatar

Avatar
Level 1
praveene2538348
Level 1

Likes

0 likes

Total Posts

4 posts

Correct reply

0 solutions
View profile

Avatar
Level 1
praveene2538348
Level 1

Likes

0 likes

Total Posts

4 posts

Correct reply

0 solutions
View profile
praveene2538348
Level 1

07-04-2019

Thanks Gaurav for your suggestion. As mentioned in the other thread, the dispatcher flush configuration was causing the issue.