Expand my Community achievements bar.

Radically easy to access on brand approved content for distribution and omnichannel performant delivery. AEM Assets Content Hub and Dynamic Media with OpenAPI capabilities is now GA.
SOLVED

Maven Build Error -cq-social-console - Could not find artifact com.adobe.cq.social:socialcommunities-parent:pom:1.4.3

Avatar

Level 4

Hi Team,

we are trying to add dependency for cq-social-console on POM and ended up in the following error, Any pointer to fix this issue will help us more

Dependency:

<dependency>

<groupId>com.adobe.cq.social</groupId>

<artifactId>cq-social-console</artifactId>

<version>1.3.0</version>

<scope>provided</scope>

</dependency>

Maven Build Error:

Caused by: org.eclipse.aether.resolution.ArtifactResolutionException: Could not find artifact com.adobe.cq.social:socialcommunities-parent:pom:1.4.3 in adobe-public-releases (https://repo.adobe.com/nexus/content/groups/public)

Thanks

Prem

1 Accepted Solution

Avatar

Correct answer by
Level 4

Thanks dwalling​ for the above pointer, that helps me resolving the build issue,

One small change on version that you mentioned, "1.10.167" is not avail on pubic repository, so we used the version "1.10.167.27"

<dependency>

<groupId>com.adobe.cq.social</groupId>

<artifactId>cq-socialcommunities-api</artifactId>

<version>1.10.167.27</version>

</dependency>

Index of /groups/public/com/adobe/cq/social/cq-socialcommunities-api

Thanks

Prem

View solution in original post

13 Replies

Avatar

Level 10

What version of AEM are you using?

Avatar

Level 4

Hi smacdonald2008

We are using Version 6.2.0.SP1-CFP12 and we do installed AEM-6.2-Communities-Livefyre-Feature-Pack-3

Maven Version - 3.2.5

Thanks

Prem

Avatar

Level 10

Have you tried using UBER AEM JAR to build code with Communities API. We do not have any HELPX Examples for this API so i cannot really point you to an article. (we will fix this this year).

Avatar

Level 4

Tried smacdonald2008​, but that didn't helped us, ended up in same error.

Thanks

Prem

Avatar

Level 10

This API should build with the UBER POM like the other AEM APIS so. I have reached out to the Eng team.

Avatar

Employee

Premkarthic​ - We are looking into this. Please wait for an update.

Avatar

Level 10

Also - Eng stated:

"you shouldn’t be declaring a dependency o cq-social-console. They should use cq-socialcommunities-api which is the same version as the FP installed. There are threads in the forum that have details"

Avatar

Level 4

smacdonald2008​ tried adding that dependency too, but import for "com.adobe.cq.social.site.api.BaseSite" is not get resolved.

<dependency>

<groupId>com.adobe.cq.social</groupId>

<artifactId>cq-socialcommunities-api</artifactId>

<version>1.9.236</version>

<scope>provided</scope>

</dependency>

So i subsequently checked on depfinder and that suggest me to add

<dependency>

<groupId>com.adobe.cq.social</groupId>

<artifactId>cq-social-console</artifactId>

<version>1.3.0</version>

<scope>provided</scope>

</dependency>

and that ended up in artifact missing error that i mentioned earlier.

Avatar

Employee

What version of AEM are you using and what version of cq-socialcommunities-pkg is installed in it? the api jar needs to match the pkg version. api 1.9.236 and console 1.3.0 are not compatible.

Avatar

Level 4

dwalling​ we are using Version 6.2.0.SP1-CFP12 and we do installed AEM-6.2-Communities-Livefyre-Feature-Pack-3,

Could you please give us the compatible version of dependencies.

Thanks

Prem

Avatar

Employee

Premkarthic​ AEM-6.2-Communities-LiveFyre-Feature-Pack-3 is this one:

https://www.adobeaemcloud.com/content/marketplace/marketplaceProxy.html?packagePath=/content/compani...

In the details tab of package share, you'll see that it is version 1.10.167. You should also be able to locate that same version of the communities package in package manager of your AEM instance.

Declare the build dependencies in the pom using the same version as follows:

<dependency>

<groupId>com.adobe.cq.social</groupId>

<artifactId>cq-socialcommunities-api</artifactId>

<version>1.10.167</version>

<scope>provided</scope>

</dependency>

Avatar

Correct answer by
Level 4

Thanks dwalling​ for the above pointer, that helps me resolving the build issue,

One small change on version that you mentioned, "1.10.167" is not avail on pubic repository, so we used the version "1.10.167.27"

<dependency>

<groupId>com.adobe.cq.social</groupId>

<artifactId>cq-socialcommunities-api</artifactId>

<version>1.10.167.27</version>

</dependency>

Index of /groups/public/com/adobe/cq/social/cq-socialcommunities-api

Thanks

Prem