Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Logs not updating in our AEM instances

Avatar

Level 2

Hi all, 

We are facing an issue since some time now. We see that we are not able to customize the logs for our AEM servers, and this is affecting multiple environments.

Logging has not stopped in our instance but it is only that when we add new logger path as class names or change log type of existing logs, it enters fine in the Logging logger configuration but is does not reflect same in the slinglogs.

We have referred to previous posts and based on suggestions deleted duplicate logs, restarted AEM instance, checked the bundles and restarted them. But nothing is working out right now. We are using AEM version 5.6 where we are facing this issue.

 

Please suggest if you have faced similar issues or have other suggestions.

1 Accepted Solution

Avatar

Correct answer by
Employee

hi @avni27 ,

 

Please check whether the sling log configuration is saved in system for eg /apps/system/config/org.apache.sling.commons.log.LogManager.factory.config.6b635d9e-0471-4b17-a7d6-8fe156912a12.config. 

 

1. If yes, then please delete the nodes and try to add them using your code base as you have created other log files.

 

2. Also, check whether the packages you are trying to provide as filter is already present in existing loggers.

 

If none of the above works then can you share your logger configuration.

 

Thanks,

Nikita Garg

View solution in original post

4 Replies

Avatar

Level 9

Hi @avni27 

 

Have you tried to use the Sling Logging console (http://localhost:4502/system/console/slinglog (in the navigation: System Console =>Sling => Log Support)?

Avatar

Level 2

Hi @AvinashGupta01 ,

I used slinglogs console to check the number and name of logger configurations. Thanks.

Avatar

Level 9

@avni27 This usally happens when you have the package inlcuded in multiple log files.  You could also check for some sort of typo error while defining it.

One method you can use to find out is to check the updated timestamp of the log files and find which log is getting updated from the crx-quickstart/logs folder.

Hope this helps.

Avatar

Correct answer by
Employee

hi @avni27 ,

 

Please check whether the sling log configuration is saved in system for eg /apps/system/config/org.apache.sling.commons.log.LogManager.factory.config.6b635d9e-0471-4b17-a7d6-8fe156912a12.config. 

 

1. If yes, then please delete the nodes and try to add them using your code base as you have created other log files.

 

2. Also, check whether the packages you are trying to provide as filter is already present in existing loggers.

 

If none of the above works then can you share your logger configuration.

 

Thanks,

Nikita Garg