Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

jquery version in AEM6.2

Avatar

Level 3

Hello,

We are upgrading AEM5.6.1 to 6.2.

We need to use at least jquery 1.9.1 or higher for some compoents so we used single jquery in 5.6.1 which is not from AEM.

We want to use a jquery provided from AEM in 6.2 using dependencies -cq:jquery and its version need to be 1.9.1 or higher.

We checked the jquery version and it is 1.8.1.

I would like to make sure what is the jquery version provided from AEM6.2.

Another question, if the jquery is 1.8.1 in AEM6.2, what is good way to use higher version jquery?

 

Thanks,

Keehwan

1 Accepted Solution

Avatar

Correct answer by
Level 10

With AEM version of JQeury - you get functionality like ability to perform CORS/AJAX without worrying about cross domain issues.

There is an older thread that talks about this issue: 

http://help-forums.adobe.com/content/adobeforums/en/experience-manager-forum/adobe-experience-manage...

 

Ove Lindström provided a good answer here too. 

View solution in original post

6 Replies

Avatar

Level 10

Just create a clientlib and for any component that uses the higher version - load the clientlib into your component. 

Avatar

Level 3

I used clientlibs and included it with jquery1.13.1 on our components.

Problem is that sometime this jquery is conflicted with jquery provided from AEM like when we use twitter compoent or some OOTB components.

So we decided to use only jquery from AEM. But I recognized that it is lower version (1.8.1).

I am not sure the jquery provided from AEM 6.2 is 1.8.1.

We want to use relative high version like 1.13.1.

Avatar

Correct answer by
Level 10

With AEM version of JQeury - you get functionality like ability to perform CORS/AJAX without worrying about cross domain issues.

There is an older thread that talks about this issue: 

http://help-forums.adobe.com/content/adobeforums/en/experience-manager-forum/adobe-experience-manage...

 

Ove Lindström provided a good answer here too. 

Avatar

Level 3

Thank you, Scott

This issue has been resolved.

The problem in our qa environment was cache in web server.

qa author and pub get correct version of jquery from AEM6.2. However webserver used old version of jquery.

After deleting cache in webserver, this problem hase been resolved.

Thanks,

Avatar

Level 10

I am glad you got it working - for others reading this - see Ove response in the thread i referenced.