Expand my Community achievements bar.

July 31st AEM Gems Webinar: Elevate your AEM development to master the integration of private GitHub repositories within AEM Cloud Manager.
SOLVED

It's an intermittent issue,On opening a page to edit in AEM, Edit mode doesn’t work initially. However, if you click to Preview mode and then back to Edit mode, it works.

Avatar

Level 2

sallewar1_0-1679031645566.png

EDIT Mode working here on the first page load.

 

 

sallewar1_1-1679031707536.png

Edit Mode not working on first page load.

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Can you please check for wereatil, if you have the same issue?
It could be the application code which is interfering with Edit button functionality.



Arun Patidar

View solution in original post

5 Replies

Avatar

Community Advisor

@sallewar1 Did you observe any errors in browser console or AEM logs.

Thanks,
Siva

Avatar

Community Advisor

@sallewar1 

If you are using Aemaacs, I would suggest updating the SDK.
Please check logs in the browser as well as in AEM, it can help to know the exact reason behind it.

 

I hope it helps!

 

Rohit

Avatar

Community Advisor

Hi @sallewar1 ,
This might happen due to some error. Please check your browser console and see if you are getting any js errors. 

Avatar

Correct answer by
Community Advisor

Can you please check for wereatil, if you have the same issue?
It could be the application code which is interfering with Edit button functionality.



Arun Patidar

Avatar

Community Advisor

Hello @sallewar1 

 

For any issues that you feel are platform specific, always test them on a vanilla instance. That is one without any custom code.

It can be just required AEM version + service pack + WKND.

 

There are cases when custom code has affected behaviour of entire instance (including WKND site). Hence, please test without your custom code first.


Aanchal Sikka