Issues with migrating mbox.js to at.js

Avatar

Avatar

samsundar23

Avatar

samsundar23

samsundar23

17-07-2020

We started our migration from mbox.js to at.js and as first step we loaded the at.js through adobe target configuration which worked well. After loading the at.js in the page, we are receiving the following error

 

Uncaught ReferenceError: mboxFactoryDefault is not defined
at aam_tnt_cb (analytics_min.js:formatted:7031)
at event?d_stuff=1&d_dst=1&d_rtbd=json&d_cts=1&d_cb=aam_tnt_cb&d_dpid=604:1

 

From our understanding, mboxFactoryDefault is deprecated and not used in at.js.

In our analytics_min.js mboxFactoryDefault.getUrlBuilder() and other methods are throw errors.

Is there any way to replace the mboxFactoryDefault or other mboxFactoryDefault related methods with ones used in at.js.
Please help.

 

at.js 2

Replies

Avatar

Avatar

Shashi_Mulugu

MVP

Avatar

Shashi_Mulugu

MVP

Shashi_Mulugu
MVP

18-07-2020

Have to followed this document 

 

https://docs.adobe.com/content/help/en/target/using/implement-target/client-side/faq-at-js/target-at...

 

Also I would suggest to post this question to Adobe target community for better reach.

Avatar

Avatar

samsundar23

Avatar

samsundar23

samsundar23

19-07-2020

Thanks for your response.

Yes, we did follow the mentioned link.
But it did not help in the resolution of the errors which are coming up due to deprecated mbox.js methods.
I have post the same in Adobe Target community as well.

 

Avatar

Avatar

samsundar23

Avatar

samsundar23

samsundar23

19-07-2020

Hi @Vaibhavi 

Can you help on this problem ?
Not sure about where to move on now.

 

Thanks

SHYAMSUNDAR TK

Avatar

Avatar

ganeshboggavara

Avatar

ganeshboggavara

ganeshboggavara

27-07-2020

Hi @samsundar23 ,

 

Can you please let me know what you have done exactly as part of the migration? I have recently done migration of mbox.js to at.js and as part of that I have installed installed Adobe TargetV2 extension and modified the All Pages - Library loaded Launch rule, I just want to confirm if that's the right way?

I am seeing CQ_Analytics is undefined console error after doing this, that's the issue i am having right now

 Appreciate your response!!!

Thanks,

Ganesh