Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Issues with migrating mbox.js to at.js

Avatar

Avatar
Validate 1
Level 2
samsundar23
Level 2

Likes

4 likes

Total Posts

56 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 3
Ignite 1
Give Back 3
Give Back
View profile

Avatar
Validate 1
Level 2
samsundar23
Level 2

Likes

4 likes

Total Posts

56 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 3
Ignite 1
Give Back 3
Give Back
View profile
samsundar23
Level 2

17-07-2020

We started our migration from mbox.js to at.js and as first step we loaded the at.js through adobe target configuration which worked well. After loading the at.js in the page, we are receiving the following error

 

Uncaught ReferenceError: mboxFactoryDefault is not defined
at aam_tnt_cb (analytics_min.js:formatted:7031)
at event?d_stuff=1&d_dst=1&d_rtbd=json&d_cts=1&d_cb=aam_tnt_cb&d_dpid=604:1

 

From our understanding, mboxFactoryDefault is deprecated and not used in at.js.

In our analytics_min.js mboxFactoryDefault.getUrlBuilder() and other methods are throw errors.

Is there any way to replace the mboxFactoryDefault or other mboxFactoryDefault related methods with ones used in at.js.
Please help.

 

at.js 2

Replies

Avatar

Avatar
Springboard
MVP
Shashi_Mulugu
MVP

Likes

200 likes

Total Posts

264 posts

Correct Reply

64 solutions
Top badges earned
Springboard
Bedrock
Validate 1
Applaud 100
Establish
View profile

Avatar
Springboard
MVP
Shashi_Mulugu
MVP

Likes

200 likes

Total Posts

264 posts

Correct Reply

64 solutions
Top badges earned
Springboard
Bedrock
Validate 1
Applaud 100
Establish
View profile
Shashi_Mulugu
MVP

18-07-2020

Have to followed this document 

 

https://docs.adobe.com/content/help/en/target/using/implement-target/client-side/faq-at-js/target-at...

 

Also I would suggest to post this question to Adobe target community for better reach.

Avatar

Avatar
Validate 1
Level 2
samsundar23
Level 2

Likes

4 likes

Total Posts

56 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 3
Ignite 1
Give Back 3
Give Back
View profile

Avatar
Validate 1
Level 2
samsundar23
Level 2

Likes

4 likes

Total Posts

56 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 3
Ignite 1
Give Back 3
Give Back
View profile
samsundar23
Level 2

19-07-2020

Thanks for your response.

Yes, we did follow the mentioned link.
But it did not help in the resolution of the errors which are coming up due to deprecated mbox.js methods.
I have post the same in Adobe Target community as well.

 

Avatar

Avatar
Validate 1
Level 2
samsundar23
Level 2

Likes

4 likes

Total Posts

56 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 3
Ignite 1
Give Back 3
Give Back
View profile

Avatar
Validate 1
Level 2
samsundar23
Level 2

Likes

4 likes

Total Posts

56 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 3
Ignite 1
Give Back 3
Give Back
View profile
samsundar23
Level 2

19-07-2020

Hi @Vaibhavi 

Can you help on this problem ?
Not sure about where to move on now.

 

Thanks

SHYAMSUNDAR TK

Avatar

Avatar
Validate 1
Level 2
ganeshboggavara
Level 2

Likes

2 likes

Total Posts

32 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile

Avatar
Validate 1
Level 2
ganeshboggavara
Level 2

Likes

2 likes

Total Posts

32 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
ganeshboggavara
Level 2

27-07-2020

Hi @samsundar23 ,

 

Can you please let me know what you have done exactly as part of the migration? I have recently done migration of mbox.js to at.js and as part of that I have installed installed Adobe TargetV2 extension and modified the All Pages - Library loaded Launch rule, I just want to confirm if that's the right way?

I am seeing CQ_Analytics is undefined console error after doing this, that's the issue i am having right now

 Appreciate your response!!!

Thanks,

Ganesh