Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Issues after applying SP1 to AEM 6.1 instance

au4liferz
Level 4
Level 4

After installing AEM-6.1-Service-Pack-1 I can't reach several sites within AEM, (even the main page at http://localhost:4502/projects.html). I get the error listed below, informing me that there are issues in  /libs/cq/experiencelog/components/head/head.jsp. This is listed as a "Known issue", and the fix is supposed to be fairly simple, (just recompile the JSPs). I've tried the following things, to no avail. The issue is still there.

1. Gone to http://localhost:4502/system/console/slingjsp, and hit the "Recompile all JSPs" button. Restarted AEM. How do I know that the JSPs have really been recompiled? I can no longer look off of /var/classes to delete the classes, and see the new ones generated. When I look on the disk at .../author/crx-quickstart/launchpad/felix/bundle218/data/classes, I don't see the date for the classes changing. I've even stopped AEM, deleted the "classes" folder, and then restarted. It will regenerate the classes folder, but how do I ensure that all JSPs, (such as the head.jsp) is recompiled??? How can I verify that they have all been regenerated, (since I can't look off of /var/classes any longer)?

2. I've rebuilt the SP1 package, and re-installed it, to no avail.

So, how do I fix this? How did others fix this? I wasn't using AEM when I applied the Service Pack, (though I did have multiple windows open to CRXDE lite, and several other sites). Could this possibly be a java version mismatch issue? Even so, recompiling all of the JSPs should clear it up, (unless I need to build certain modules prior to compiling them to ensure that annotations, (e.g. @Component, are translated correctly etc.)).

 

Error:

Cannot serve request to /projects.html in /libs/cq/experiencelog/components/head/head.jsp Exception: org.apache.sling.scripting.jsp.jasper.JasperException: Unable to compile class for JSP: An error occurred at line: 6 in the generated java file Only a type can be imported. com.adobe.cq.experiencelog.ExperienceLogConfig resolves to a package An error occurred at line: 24 in the jsp file: /libs/cq/experiencelog/components/head/head.jsp ExperienceLogConfig cannot be resolved to a type 21: %><%@taglib prefix="cq" uri="http://www.day.com/taglibs/cq/1.0" %><% 22: %><cq:defineObjects /><% 23: 24: ExperienceLogConfig experienceLogConfig = sling.getService(ExperienceLogConfig.class); 25: if (experienceLogConfig.isEnabled(slingRequest)) { 26:     %><script src="<%=xssAPI.encodeForHTMLAttr(experienceLogConfig.getTrackingScript())%>"></script><% 27: }
26 Replies
Opkar_Gill
Employee
Employee

Was 218 the bundle ID for the org.apache.sling.commons.fsclassloader bundle as seen in the system console. If you delete all the class files on the hard disk, are they re-created when you restart and open the projects.html page?

Regards,

Opkar

au4liferz
Level 4
Level 4

Opkar Gill wrote...

Was 218 the bundle ID for the org.apache.sling.commons.fsclassloader bundle as seen in the system console. If you delete all the class files on the hard disk, are they re-created when you restart and open the projects.html page?

Regards,

Opkar

 

Yes, 218 was the bundle ID for the FSC ClassLoader, and yes again, when I deleted the "classes" folder, and restarted AEM, it re-generated the "classes folder", (so I know all JSPs under that folder were re-generated, and I'm ASSUMING that they were  re-built, and re-compiled in order to re-generate them).

Note: to potentially improve the Adobe documentation, (e.g. Installation notes etc.). The documentation tells you to locate the bundle ID for the FSC ClassLoader, but don't tell you how to do that, (in detailed steps). It also tells you to "recompile all JSPs", but doesn't go into detail telling new users exactly how to do that either.

Opkar_Gill
Employee
Employee

You mentioned a Java versions mismatch, did you change the version of java you were using after the upgrade? 

Regards,

Opkar

Lokesh_Shivalingaiah
Community Advisor
Community Advisor

It looks like an issue. Even I am facing the same problem. Please log a daycare ticket

au4liferz
Level 4
Level 4

alin7ilie wrote...

So was this solved? I'm seeing the exact same issue.

 

As bsloki suggested, please log a daycare ticket and then report back with the resolution. If enough of us log tickets, they may go ahead and determine the root cause of the issue instead of just saying you should restore from your backup, (which really isn't a resolution at all).

smacdonald2008
Level 10
Level 10

Heard back from support Eng members: 

I saw the same exact issue with a customer yesterday.  We were able to fix it by going to /system/console/slingjsp and force recompiling of the jsp files.

Lokesh_Shivalingaiah
Community Advisor
Community Advisor

Thanks @scott - that would help. I have done that and it works ! 

But can you check with them why do we have to do ? As it jsp has to be compiled every time you start an instance.

cqvoyager
Level 4
Level 4

I'm getting this issue in the QA environment after restarting the AEM instance. I tried recompiling the jsp classes as mentioned in the release notes but of no use.

https://docs.adobe.com/docs/en/aem/6-1/release-notes-sp1.html

Accessing touch-optimized UI while 6.1 SP1 is getting installed can cause JSP compilation problem with error like below. To resolve this issue, clear the compiled classes using the web console plug-in available at http://<host>:<port>/system/console/slingjsp
*ERROR*​ [GET /projects HTTP/1.1] org.apache.sling.engine.impl.SlingRequestProcessorImpl service: Uncaught SlingException java.lang.Error: Unresolved compilation problems: Only a type can be imported. com.adobe.cq.experiencelog.ExperienceLogConfig resolves to a package

Additional information is some of the bundles are in installed state. Bundle information: 452 bundles in total, 420 bundles active, 8 active fragments, 24 bundles installed

Opkar_Gill
Employee
Employee

what happens when you try and start the installed bundles?

cqvoyager
Level 4
Level 4

Adobe CQ Experience Log Client Bundlecom.adobe.cq.cq-experiencelog was one of the 24 bundles. when I try to start them I'm seeing this in the logs.

03.06.2016 15:12:35.599 *ERROR* [qtp1321212999-418] org.apache.felix.http.jetty %bundles.pluginTitle: Cannot start (org.osgi.framework.BundleException: Unresolved constraint in bundle com.adobe.cq.cq-experiencelog [466]: Unable to resolve 466.0: missing requirement [466.0] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.cq.experiencelog)(version>=1.0.0)(!(version>=2.0.0))))
org.osgi.framework.BundleException: Unresolved constraint in bundle com.adobe.cq.cq-experiencelog [466]: Unable to resolve 466.0: missing requirement [466.0] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.cq.experiencelog)(version>=1.0.0)(!(version>=2.0.0)))
        at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4095)
        at org.apache.felix.framework.Felix.startBundle(Felix.java:2114)
        at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:977)
        at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:964)
        at org.apache.felix.webconsole.internal.core.BundlesServlet.doPost(BundlesServlet.java:365)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:644)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:725)
        at org.apache.felix.webconsole.internal.servlet.OsgiManager.service(OsgiManager.java:555)
        at org.apache.felix.webconsole.internal.servlet.OsgiManager$3.run(OsgiManager.java:459)
        at java.security.AccessController.doPrivileged(Native Method)
        at org.apache.felix.webconsole.internal.servlet.OsgiManager.service(OsgiManager.java:455)
        at org.apache.felix.http.base.internal.handler.ServletHandler.doHandle(ServletHandler.java:336)
        at org.apache.felix.http.base.internal.handler.ServletHandler.handle(ServletHandler.java:297)
        at org.apache.felix.http.base.internal.dispatch.ServletPipeline.handle(ServletPipeline.java:93)
        at org.apache.felix.http.base.internal.dispatch.InvocationFilterChain.doFilter(InvocationFilterChain.java:50)
        at org.apache.felix.http.base.internal.dispatch.HttpFilterChain.doFilter(HttpFilterChain.java:31)
        at org.apache.sling.i18n.impl.I18NFilter.doFilter(I18NFilter.java:129)
        at org.apache.felix.http.base.internal.handler.FilterHandler.doHandle(FilterHandler.java:108)
        at org.apache.felix.http.base.internal.handler.FilterHandler.handle(FilterHandler.java:80)
        at org.apache.felix.http.base.internal.dispatch.InvocationFilterChain.doFilter(InvocationFilterChain.java:46)
        at org.apache.felix.http.base.internal.dispatch.HttpFilterChain.doFilter(HttpFilterChain.java:31)
        at org.apache.sling.security.impl.ReferrerFilter.doFilter(ReferrerFilter.java:290)
        at org.apache.felix.http.base.internal.handler.FilterHandler.doHandle(FilterHandler.java:108)
        at org.apache.felix.http.base.internal.handler.FilterHandler.handle(FilterHandler.java:80)
        at org.apache.felix.http.base.internal.dispatch.InvocationFilterChain.doFilter(InvocationFilterChain.java:46)
        at org.apache.felix.http.base.internal.dispatch.HttpFilterChain.doFilter(HttpFilterChain.java:31)
        at com.adobe.granite.license.impl.LicenseCheckFilter.doFilter(LicenseCheckFilter.java:308)
        at org.apache.felix.http.base.internal.handler.FilterHandler.doHandle(FilterHandler.java:108)
        at org.apache.felix.http.base.internal.handler.FilterHandler.handle(FilterHandler.java:80)
        at org.apache.felix.http.base.internal.dispatch.InvocationFilterChain.doFilter(InvocationFilterChain.java:46)
        at org.apache.felix.http.base.internal.dispatch.HttpFilterChain.doFilter(HttpFilterChain.java:31)
        at org.apache.felix.http.sslfilter.internal.SslFilter.doFilter(SslFilter.java:89)
        at org.apache.felix.http.base.internal.handler.FilterHandler.doHandle(FilterHandler.java:108)
        at org.apache.felix.http.base.internal.handler.FilterHandler.handle(FilterHandler.java:80)

cqvoyager
Level 4
Level 4

we submitted a day care ticket and Adobe provided a hot fix which solved the issue. Hope it helps others!!

suvasishm
Level 2
Level 2

What is the hot fix number?

Facing exactly the same issue.

suvasishm
Level 2
Level 2

Thanks for sharing.

Here is another solution that worked for me - http://goo.gl/K3MiTH

deisbel_diaz
Level 2
Level 2

It does not work for me. I'm still having the same problem. 

vishwanath881
Level 4
Level 4

It works some times but not all the time. 

Any update on this ?

au4liferz
Level 4
Level 4
 

bsloki wrote...

It looks like an issue. Even I am facing the same problem. Please log a daycare ticket

 

I logged daycare tickets, but they were not able to help. They had me go through all of the basic steps, but ultimately told me to restore from my backup, (which isn't much helped in resolving the root cause of this issue). Seems as if whenever problem resolution is really tough, the default answer is to "restore from your backup" smiley

jerrys49113842
Level 3
Level 3

I did the same. Support couldn't help me. 

As I was updating more machines and I forgot to login as "admin"  in one instance, I guessed that it was that machine. Installing the SP1 as user with "admin role" isn't the same as installing it as user "admin".

 

JS