Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Is there a way to connect Launch to an Experience Fragment?

james-mke
Level 2
Level 2

I would like to connect our Adobe Launch tool to Experience Fragments so that we can leverage the rules and data elements for analytics and functionality purposes. We currently connect the Launch platform using the Advanced tab Cloud Configuration path.

 

We are working on iframing Experience Fragments into a virtual trade show application that we are hosting and would like the analytics pieces to fire within the iFrame window.

 

If there are alternate ideas to make this work I look forward to hearing ideas.

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

1 Accepted Solution
raj_mandalapu
Correct answer by
Community Advisor
Community Advisor

@james-mke When you inspect the iframe content, do you see launch script loading? if the launch script is loading and still not triggering then it could be a cross-domain issue. do you see any cors issue in the browser console?

 

I tested this in the same domain by loading XF's in the Iframe's and the analytics script is loading and tracking. here the XF's, iframe and pages are in the same AEM application.

 

You can also try loading the launch script in the virtual trade show application instead of XF's and read elements via iframe content, refer below link 

https://experienceleague.adobe.com/docs/analytics/implementation/use-cases/iframe.html?lang=en#acces...

 

 

 

 

View solution in original post

2 Replies
raj_mandalapu
Correct answer by
Community Advisor
Community Advisor

@james-mke When you inspect the iframe content, do you see launch script loading? if the launch script is loading and still not triggering then it could be a cross-domain issue. do you see any cors issue in the browser console?

 

I tested this in the same domain by loading XF's in the Iframe's and the analytics script is loading and tracking. here the XF's, iframe and pages are in the same AEM application.

 

You can also try loading the launch script in the virtual trade show application instead of XF's and read elements via iframe content, refer below link 

https://experienceleague.adobe.com/docs/analytics/implementation/use-cases/iframe.html?lang=en#acces...

 

 

 

 

View solution in original post

james-mke
Level 2
Level 2
Thank you Raj. I suspected that loading the Launch script into the trade show site may be the next best solution. We can try that.